Python Class Library for Numbers package.

David Nicholls david at
Mon Apr 26 01:22:57 PDT 2010

OK, I've worked on this a bit further.

I have installed the MacPorts 'cln' package - it installs the cln/ 
directory in /opt/local/include/

With that in place, the calcrpn-py package installs OK. (It is needed by 

The next step is to install the clnum module, as per  I can't get it to 
find the numerous .h files that need to be included, because of a path 

I'm pretty sure that the problem lies in the command as given on the 
above web page (run from within ipython run via sudo):

run install --prefix=/usr/local

The various '.h' files have a whole bunch of #include statements with 
files named like 'cln/xxx.h'

A typical line is:

#include "cln/types.h"

and the install process cannot find any of the "cln/xxx.h" files.

Hoping that there was some sort of global prefix process I could use, I 
have tried a variety of "--prefix=..." variants without any luck.  (eg 

I could replace all the 'cln/' strings in the .h files and in clnum.cpp 
with '/opt/local/include/cln/' (and there are dozens of them in a lot of 
files) but that's pretty crude and I'm sure there's a more elegant way.

Any suggestions?


ANU RSAA Mt Stromlo

More information about the macports-users mailing list