install of `sbcl' failed

joerg van den hoff j.van_den_hoff at
Mon Apr 26 11:48:06 PDT 2010

ryan, rainer,

really thanks a lot for bothering with this.

On Mon, 26 Apr 2010 20:07:31 +0200, Ryan Schmidt <ryandesign at>  

> On Apr 26, 2010, at 09:46, joerg van den hoff wrote:
>> DEBUG: Skipping completed org.macports.fetch (sbcl)
>> DEBUG: Skipping completed org.macports.checksum (sbcl)
>> DEBUG: setting option extract.cmd to /usr/bin/bzip2
>> DEBUG: Skipping completed org.macports.extract (sbcl)
>> DEBUG: Skipping completed org.macports.patch (sbcl)
>> DEBUG: Skipping completed org.macports.configure (sbcl)
>> --->  Building sbcl
>> DEBUG: Executing (sbcl)
>> sh: line 0: cd:  
>> /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_sbcl/work/sbcl-1.0.37:  
>> No such file or directory
>> this happened both with 10.5 on ppc as well as 10.6 on i386
>> I see there is a 'no such file' problem but how does this come about?  
>> any ideas?
> Since it works for Rainer and for me, I can only suggest that you  
> somehow successfully completed sbcl's extract phase, then perhaps  
> interrupted the installation, then deleted the extracted directory. I'd  
> suggest you start on both machines by cleaning the port and trying again.

actually, I did not. what I did in the first place was trying to install  

sudo port install maxima

which led _directly_ (without any intervention on my side) to the reported  
error (the final one, that the make target could
not be executed).

> sudo port clean sbcl
> sudo port -d install sbcl
> If it fails again, send us the complete debug output this will produce.

this worked (and it's completely my fault that I did not try this tidy up  
in the first place before posting). so: problem solved for me, thanks a  

I have no idea why it failed in the first place. I can only guess:  
installing `maxima' has been failing (with unrelated errors) for quite  
some time (last I tried was a few months ago) but very probably I did  
_not_ do `port clean maxima' in between. whether or not this could've let  
to a state of the ports tree which caused the present problem I cannot say.

anyway, really thanks a lot to both of you again!



More information about the macports-users mailing list