gv and ghostscript

Ryan Schmidt ryandesign at macports.org
Tue Apr 27 01:13:23 PDT 2010

Please Reply All so our conversation stays on the list, not in private mail.

On Apr 27, 2010, at 01:35, John B Brown wrote:
> On 4/26/10 6:44 PM, Ryan Schmidt wrote:
>> gs and gv work fine for me on 10.6.3.
>> You only need one set of X libraries, either Xorg or XFree86. Installing both may be the source of the problem. On Mac OS X these days, Xorg is expected to be used. XFree86 isn't really being maintained in MacPorts. (You may notice XFree86 4.8.0 was released in December 2008 but MacPorts still has version 4.7.0. Possibly we should even remove XFree86 from MacPorts.) Try uninstalling XFree86.
> 	I installed gv first; there was a huge amount of stuff that had to be automatically installed to get gv in.

Yes, there is.

> Then I installed Xorg after neither gv nor ghostscript worked when first installed by port.

gv and ghostscript depend on the parts of xorg they supposedly require, so those parts should already have been installed. So when you say you "installed Xorg" what exactly do you mean? What ports did you install?

> Then I tried XFree86, and they also didn't work after installing that.

I tried installing the XFree86 port and I couldn't get it to build. You really got this to install? "port installed XFree86" shows that it is installed?

> 	Should I just Trash /opt/local and try again?

If you wish to uninstall MacPorts and start over, correct uninstall instructions are in the guide:


> Part of the way through all the macport stuff Apple dropped some updates into this box. Xcode was one of them and Java was another.

That should be fine.

> I did bootstrap a compile of gcc-4.4.3 into /usr/local a long time back, so I can always set that as the path for gcc in my PATH, but there's no glibc in this crap box, so that doesn't do me any good; wipe will compile, but it doesn't work here.

That could possibly be a problem. It's not supported to have anything in /usr/local while using MacPorts because such things often interfere with software installed using MacPorts. You should remove this and anything else in /usr/local. If you still need gcc 4.4, it's available in the gcc44 port. It's possible software you've already installed using MacPorts has already linked with software you installed in /usr/local. If so, such software should now fail to run, saying the library it linked with in /usr/local couldn't be found. If that's the case, rebuild the affected port. Or you could uninstall all of MacPorts and reinstall, to be sure you get everything.

More information about the macports-users mailing list