gv and ghostscript

John B Brown jbb at vcn.com
Tue Apr 27 08:13:04 PDT 2010

On 4/27/10 2:13 AM, Ryan Schmidt wrote:
> Please Reply All so our conversation stays on the list, not in private mail.
> On Apr 27, 2010, at 01:35, John B Brown wrote:
>> On 4/26/10 6:44 PM, Ryan Schmidt wrote:
>>> gs and gv work fine for me on 10.6.3.
>>> You only need one set of X libraries, either Xorg or XFree86. Installing both may be the source of the problem. On Mac OS X these days, Xorg is expected to be used. XFree86 isn't really being maintained in MacPorts. (You may notice XFree86 4.8.0 was released in December 2008 but MacPorts still has version 4.7.0. Possibly we should even remove XFree86 from MacPorts.) Try uninstalling XFree86.
>> 	I installed gv first; there was a huge amount of stuff that had to be automatically installed to get gv in.
> Yes, there is.
>> Then I installed Xorg after neither gv nor ghostscript worked when first installed by port.
> gv and ghostscript depend on the parts of xorg they supposedly require, so those parts should already have been installed. So when you say you "installed Xorg" what exactly do you mean? What ports did you install?

	After running 'sudo port install gv' and then 'sudo port install 
ghostscript' I ran 'sudo port install Xorg'. The install appeared to be 
sucessful showing an installed Xorg line.

>> Then I tried XFree86, and they also didn't work after installing that.
> I tried installing the XFree86 port and I couldn't get it to build. You really got this to install? "port installed XFree86" shows that it is installed?

	I ran 'sudo port install XFree86' and it ended with an installed 
XFree86 line.

>> 	Should I just Trash /opt/local and try again?
> If you wish to uninstall MacPorts and start over, correct uninstall instructions are in the guide:
> http://guide.macports.org/chunked/installing.macports.uninstalling.html
>> Part of the way through all the macport stuff Apple dropped some updates into this box. Xcode was one of them and Java was another.
> That should be fine.
>> I did bootstrap a compile of gcc-4.4.3 into /usr/local a long time back, so I can always set that as the path for gcc in my PATH, but there's no glibc in this crap box, so that doesn't do me any good; wipe will compile, but it doesn't work here.
> That could possibly be a problem. It's not supported to have anything in /usr/local while using MacPorts because such things often interfere with software installed using MacPorts. You should remove this and anything else in /usr/local. If you still need gcc 4.4, it's available in the gcc44 port. It's possible software you've already installed using MacPorts has already linked with software you installed in /usr/local. If so, such software should now fail to run, saying the library it linked with in /usr/local couldn't be found. If that's the case, rebuild the affected port. Or you could uninstall all of MacPorts and reinstall, to be sure you get everything.

Might you explain exactly what /usr/local has to do with /opt/local. 
Because all activity for port takes place under /opt/local what does 
having applications in /usr/local do that would interfere with port when 
a properly set up PATH is in operation?

/usr/local is helpful for such utilities as a proper updatedb and locate 
because the ones Apple sends is about as lame as can be. Is Macports 
another Apple exclusionary software system?

Is there a Linux system that will run on this iMac? At least Linux runs 
everything you successfully compile. It knows how to handle 'duplicate' 
library names.


My library load sets are below:



I compiled, and use constantly, the Schily cdtools with zero problems 
and they certainly path behind /opt/local as well as everything else.



	John B. Brown.
	[jbb at vcn.com]
	358 High Street,
	Buffalo, Wyoming

"Freedom is not worth having if it does not include
the freedom to make mistakes"  Mahatma Gandhi
"If any question why we died, tell them,
because our fathers lied."  Rudyard Kipling
"A man who does not know the truth is just an idiot
but a man who knows the truth and calls it a lie
is a crook."  Bertolt Brecht
"I wonder whether the world is being run
by smart people who are putting us on
or by imbeciles who really mean it."  Mark Twain

More information about the macports-users mailing list