necessary info

John B Brown jbb at
Wed Apr 28 16:07:31 PDT 2010

On 4/28/10 2:35 PM, Michael Funk wrote:
> On Apr 28, 2010, at 11:46 AM, John B Brown wrote:
>> 	I'm confused. According to the install DVDs that came with this iMac, the only way X11 gets in is if I install it from the DVD.
> That's correct, it doesn't get installed by default, you have to do it manually.
>> 	My screen appears no different after installing X11. How might I determine whether or not X11 is running? Does X11 install into the root tree locations that are used in Linux? I notice the /etc/X11/ paths are completely symbolic links into /usr/X11/lib.
> It won't look any different.  You should now have /Applications/Utilities/  Launch this just by double clicking it in Finder.  You should see an X11 icon in your Dock, and after a few seconds an xterm window should open up.  If both of these things happen, then X11 is working correctly on your system.
> The X server for OS X doesn't talk directly to the graphics hardware or take over your screen.  When the X server is running, each X11 app you launch will just open up in its own window like any other app.
>> 	Is 'launchd' part of the boot system?
> Yeah, it's the equivalent of 'init' on other Unix systems.  It can also launch things on demand.  Specifically, you shouldn't ever have to manually launch the X server on OS X.  You just launch an X11 application (like xterm or whatever), the app tries to connect to a local socket which is associated with the X server, and if the X server isn't already running, then launchd is smart enough to launch it for you.
>> 	The brief mention in "Mac OS X Support Essentials v10.6" by Kevin M. White, Apple Certified, says Apple X11 is based on XFree86 and X11 can be accessed by opening the X11 interface located at /Applications/Utilities/X11. It then refers all other questions about X11 to Such irrelevant subjects as 'remote ssh', forwarding, tunneling are mentioned there as examples of X11 configurations. Not exactly simple user help.
> Well, these are all pretty advanced topics, I wouldn't expect them to write up an 'Intro to X11'-type of thing.  I think their attitude is that if someone is technical enough to want to run X11 apps on their Mac, no simple user help is required.  That said, I wish there was a little more documentation for this stuff.
>> 	I just tried startx. X11 would not launch. The error message:
> I wouldn't expect startx to work, since that launches a window manager among other things.  Normally you wouldn't run X11 with a window manager on a Mac, since the X server doesn't take over the screen and the apps just open up in standalone windows.  Supposedly you can run the X server in full screen mode and use your own window manager and so on, but I've never tried doing that and don't know what's involved.
>> dyld: Library not loaded: /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ImageIO.framework/Versions/A/Resources/libTIFF.dylib
>>   Referenced from: /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ImageIO.framework/Versions/A/ImageIO
>>   Reason: Incompatible library version: ImageIO requires version 1.0.0 or later, but libTIFF.dylib provides version 0.0.0
> Not sure what might be causing this, but since you don't need to run startx, I wouldn't worry about it unless you run into it in some other context.
>> 	I've seen that error message before, during compiles that try to link libTIFF.dylib from the Apple default location. How do I overcome poorly integrated Apple libraries?
> They're pretty well integrated, no one should be directly linking to that build of libtiff anyway.  Since it's deep in the framework directory (as opposed to just sitting out in the open in /usr/lib), it should be thought of as being private to the ImageIO framework.  It's not there for anything else to link to.  If you want to use libtiff directly for anything, I'd suggest building it yourself or using the libtiff port.
>    Good luck,
>      Mike

	Running from Utilities under Applications results in the 
following error message in a separate window.

> Process:         X11.bin [160]
> Path:            /Applications/Utilities/
> Identifier:      org.x.X11
> Version:         ??? (???)
> Build Info:      X11server-850200~13
> Code Type:       X86-64 (Native)
> Parent Process:  launchd [93]
> Date/Time:       2010-04-28 16:48:22.241 -0600
> OS Version:      Mac OS X 10.6.3 (10D578)
> Report Version:  6
> Interval Since Last Report:          15785 sec
> Crashes Since Last Report:           4167
> Per-App Crashes Since Last Report:   2227
> Anonymous UUID:                      AE7A43E3-F36C-4405-AA46-4AFCF3952DAA
> Exception Codes: 0x0000000000000002, 0x0000000000000000
> Crashed Thread:  0
> Dyld Error Message:
>   Library not loaded: /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ImageIO.framework/Versions/A/Resources/libTIFF.dylib
>   Referenced from: /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ImageIO.framework/Versions/A/ImageIO
>   Reason: Incompatible library version: ImageIO requires version 1.0.0 or later, but libTIFF.dylib provides version 0.0.0
> Model: iMac9,1, BootROM IM91.008D.B08, 2 processors, Intel Core 2 Duo, 3.06 GHz, 4 GB, SMC 1.45f0
> Graphics: NVIDIA GeForce GT 130, NVIDIA GeForce GT 130, PCIe, 512 MB
> Memory Module: global_name
> AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x8E), Broadcom BCM43xx 1.0 (
> Bluetooth: Version 2.3.1f4, 2 service, 2 devices, 1 incoming serial ports
> Network Service: Ethernet, Ethernet, en0
> Serial ATA Device: ST31000342ASQ, 931.51 GB
> Serial ATA Device: HL-DT-ST DVDRW  GA11N
> USB Device: Built-in iSight, 0x05ac  (Apple Inc.), 0x8502, 0x24400000
> USB Device: IR Receiver, 0x05ac  (Apple Inc.), 0x8242, 0x04500000
> USB Device: USB Hub, 0x05e3  (Genesys Logic, Inc.), 0x0604, 0x06400000
> USB Device: Trackball, 0x046d  (Logitech Inc.), 0xc404, 0x06420000
> USB Device: Logitech USB Keyboard, 0x046d  (Logitech Inc.), 0xc315, 0x06200000
> USB Device: BRCM2046 Hub, 0x0a5c  (Broadcom Corp.), 0x4500, 0x06100000
> USB Device: Bluetooth USB Host Controller, 0x05ac  (Apple Inc.), 0x8215, 0x06110000

	As you can plainly see, trying to start X11 using the utility 
results in exactly the same versioning error; startx has nothing to do 
with that error.

	As I said before, its an Apple built-in error; Apple compiled and 
installed the library. This is the result of the regular update which 
drops new binary sets down the wire as they are produced and Apple 
releases them. In this case it was an Xcode update; I certainly never 
compiled that mis-versioned library.

	So, X11 wont run now because of that version error.

	Any suggestions?

	Incidentally, the box the error appeared in had this.

"This report will be sent to apple automatically."

	That's my typing; the box wont let me copy and paste from its facia. 
There's bunches more on the facia, but I'm not going to type it all out.


	John B. Brown.
	[jbb at]
	358 High Street,
	Buffalo, Wyoming

"Freedom is not worth having if it does not include
the freedom to make mistakes"  Mahatma Gandhi
"If any question why we died, tell them,
because our fathers lied."  Rudyard Kipling
"A man who does not know the truth is just an idiot
but a man who knows the truth and calls it a lie
is a crook."  Bertolt Brecht
"I wonder whether the world is being run
by smart people who are putting us on
or by imbeciles who really mean it."  Mark Twain

More information about the macports-users mailing list