libjit errors

Ryan Schmidt ryandesign at
Mon Aug 30 17:52:01 PDT 2010

On Aug 30, 2010, at 10:24, Balint Joo wrote:

> I've been trying to install the libJIT port. (MacPorts 1.9.1), the OS is MacOS X 10.6.4.
> My first attempt wanted to install libjit-0.0.6, and failed with a checksum error.
> I posted this as a bug on the trac site:
> A short email conversation suggested that the latest version is 0.1.2 as indeed
> confirmed by 'port livecheck':
> libjit seems to have been updated (port version: 0.0.6, new version: 0.1.2)
> Attempting to install the latest version with
> port install libjit version=0.1.2

This does nothing; MacPorts does not have the ability to install an arbitrary version of software specified on the command line; you can only install the version specified in the Portfile. You can also convince it to install an older version for which a Portfile has existed in the past; for that, see:

> Also failed for me with checksum errors. I tried following the HOWTO about
> upgrading packages (namely, edit the portfile, bump the version to 0.1.2,
> and then run port -d checksum to get the new checksums). Now the install
> gets past the download and checksum stage and fails in the configure....
> According to the log:
> :info:configure sh: line 0: cd: /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_libjit/work/libjit-0.1.2: No such file or directory
> Indeed if I look there is only a:
> /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_libjit/work
> and the only file in it is: .macports.libjit.state

The problem you're running into is that the download location listed in the portfile is on a domain name whose registration was allowed to lapse and was acquired by a domain name squatter. Their server is configured to deliver an HTML advertisement regardless what URL you request. So even when you request the URL of a software distfile, they will return to you this HTML page instead of an error. MacPorts 1.9.2 will have a better error message in this case advising you of this problem. The checksums you computed when you updated the port were of this HTML page. MacPorts then tried to extract the HTML page as if it were a distfile, which of course doesn't work. Due to another bug, MacPorts does not detect errors when extracting a distfile and proceeds on to the configure phase anyway, which then failed because the configure script was not found. Indeed, as you discovered, no files were found, because nothing could be extracted.

I found where the software is now being hosted (GNU), and updated the port to version 0.1.2. Unfortunately it does not compile and I don't know how to make it compile at the moment. I filed a ticket with my findings so far:

If someone else can complete this update, please do.

> This has been frustrating me for some time.
> Can someone please help with a concise
> way of how to get the latest versions of the ports, libjit in particular?

I don't think I can offer you any general-purpose advice, beyond what you already know (update the version and checksums in the portfile). Each piece of software is unique and often needs its own tweaks when being updated. Sometimes, as may be the case for libjit, we must contact the developers of the software for assistance if we cannot get it to compile.

> (I am having similar issues also trying to install Intel TBB v3.0. The default package is v2.2 but livecheck claims a more recent one...)

The tbb port at least has a maintainer, so hopefully he will respond to the existing tickets about his port:!closed&summary=~tbb

The port is also openmaintainer so anybody else with commit access can feel free to try to fix it.

More information about the macports-users mailing list