SLONY1 port - Snow Leopard - HELP, URGENT !

Ryan Schmidt ryandesign at
Thu Feb 4 13:07:58 PST 2010

On Feb 3, 2010, at 17:16, Jefferey Lockyer wrote:

> Having an issue building SLONY1 with Postgres84-Server port. 
> Postgres builds fine, but Slony1 yields the following error
> This is installing on a Xserve 10.6.2 Snow Leopard environment.
> -------------------
> :info:build /usr/bin/gcc-4.2 -pipe -O2 -arch x86_64 -Wall -Wmissing-prototypes -Wmissing-declarations -I../.. -DPGSHARE="\"/opt/local/shar$
> :info:build In file included from parser.y:1101:
> :info:build scan.c:161: error: conflicting types for 'yyleng'
> :info:build parser.y:25: error: previous declaration of 'yyleng' was here
> :info:build scan.c:288: error: conflicting types for 'yyleng'
> :info:build parser.y:25: error: previous declaration of 'yyleng' was here
> :info:build make[2]: *** [parser.o] Error 1
> :info:build make[1]: *** [all] Error 2
> :info:build make: *** [all] Error 2
> :info:build shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_databases_s$
> :error:build Target returned: shell command failed
> -------------------
> Bison is up to date, Flex is up to date, Yacc up to date (All required headers I can think of)
> I originally thought building from source might be a problem, but I get the same error when I run "make install" after having configure complete properly.

I see a few hits for that error message on Google, including this thread from November 2009 which says you need to install the yacc, bison and/or flex development packages (in MacPorts, there are not separate development packages; the main ports provide any applicable development headers):!!!!!!1-td26505342.html

And this bug from January 2010, which has no comments:

slony1 builds fine for me on Snow Leopard on a MacBook Pro Core 2 Duo if I have flex 2.5.35 from MacPorts installed. But I am able to reproduce the error if I don't have MacPorts flex 2.5.35 and the build instead uses Snow Leopard's flex 2.5.35. (Curious that the Snow Leopard and MacPorts versions of flex behave differently, though they claim to be the same version.) Therefore I guess you do not have the flex port installed, and suggest you install it. I also suggest you file a bug report about this problem in the MacPorts issue tracker so the maintainer can add a build dependency on flex to the slony1 port to prevent this problem in the future.

More information about the macports-users mailing list