py25-modulegraph-devel: conflicting version information

Walter Scheper ratlaw at
Thu Feb 11 07:43:04 PST 2010

Hello all,

I'm trying to build git-cola, an application that depends on py2app, which in turn depends on modulegraph. When I try to build the application it appears that modulegraph is reporting it's version as which causes to raise a VersionConflict exception because it requires modulegraph>=0.7.3.

The conflicting part comes in when I look at __version__ in modulegraph/, which is set to 0.7.1. 

This leaves me with two questions: is the version of modulegraph that is installed 0.7.3 (as suggested by macports) or 0.7.1 (as suggested by, and where exactly is dredging up

Output of trying to build git-cola follows:

$ make
python build
running build_translations
running build
running build_scripts
python darwin/ py2app
Traceback (most recent call last):
  File "darwin/", line 34, in <module>
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/distutils/", line 112, in setup
    _setup_distribution = dist = klass(attrs)
  File "/opt/local/lib/python2.5/site-packages/setuptools/", line 260, in __init__
  File "/opt/local/lib/python2.5/site-packages/setuptools/", line 284, in fetch_build_eggs
    parse_requirements(requires), installer=self.fetch_build_egg
  File "/opt/local/lib/python2.5/site-packages/", line 569, in resolve
    raise VersionConflict(dist,req) # XXX put more info here
pkg_resources.VersionConflict: (modulegraph (/opt/local/lib/python2.5/site-packages), Requirement.parse('modulegraph>=0.7.3'))
make: *** [darwin] Error 1

Walter Scheper

More information about the macports-users mailing list