Error installing p5-net-libidn

Scott Haneda talklists at
Fri Feb 12 15:26:41 PST 2010

On Feb 12, 2010, at 3:06 PM, Ryan Schmidt wrote:

> On Feb 12, 2010, at 17:03, Scott Haneda wrote:
>> On Feb 12, 2010, at 2:46 PM, Ryan Schmidt wrote:
>>> On Feb 12, 2010, at 16:42, Scott Haneda wrote:
>>>> On Feb 11, 2010, at 7:36 PM, Ryan Schmidt wrote:
>>>> Though I would love to know why it is defaulting to 1386 when I am clearly not on that architecture, and none of the other 12 or so p5's had issues, and there were about 6 or so more, which I suspect are going to go in clean as well.
>>> I am as baffled as you. I cannot explain why it's defaulting to i386 on your system in this case. Let us know if you find out why.
>> Are you on Intel, does it do it for you?  Any other people with various systems mind trying?
>> If you are, and please correct me if I am wrong, but you will want to run this
>> sudo port -f uninstall libidn
>> sudo port clean libidn p5-net-libidn
>> sudo port -d install p5-net-libidn 2>&1 | tee ~/Desktop/p5-net-libidn.txt
> Yes, I am on an Intel Core 2 Duo. (Snow Leopard doesn't run on PowerPC.) It defaults to x86_64 like it should. I tried those commands before I sent them to you and they work fine here.

Well I just diff'd macports.conf, sources.conf, and variants.comf with each respective *.default and all are identical.

Do you see anything out of whack in there?  After I run some tests, we should know more.  Any other files we may want to md5 compare on?  I am not looking forward to nuking and reinstalling things, I sort of have them just how I want them.

Could it be related to another p5?  I did this:
cd ~/macports/mail/ASSP
sudo port -d install

The only thing in there that matter in any way are:
depends_run         bin:perl:perl5.8
use_configure       no

I commented this out, as it is not needed:
#configure {}

Then I have all these to go in:
depends_lib         port:p5-io-compress \
                    port:p5-digest-md5 \
                    port:p5-digest-sha1 \
                    port:p5-email-mime-modifier \
                    port:p5-email-send \
                    port:p5-email-valid \
                    port:p5-file-readbackwards \
                    port:p5-io-socket-ssl \
                    port:p5-libwww-perl \
                    port:p5-mail-spf \
                    port:p5-mail-srs \
                    port:p5-net \
                    port:p5-net-cidr-lite \
                    port:p5-net-dns \
                    port:p5-net-ip-match-regexp \
                    port:p5-net-senderbase \
                    port:p5-net-syslog \
                    port:p5-perl-ldap \
                    port:p5-sys-syslog \
                    port:p5-tie-dbi \
                    port:p5-time-hires \
                    port:p5-io-socket-ssl \
                    port:p5-email-send \
                    port:p5-text-iconv \

Maybe it was a combo of those that messed something up?  Just a random thought, as I am confused, this seems a lot deeper than that, as it is a compile time flag correct?  That is part of core/base, and no port should be altering it?
Scott * If you contact me off list replace talklists@ with scott@ * 

More information about the macports-users mailing list