"sudo port upgrade outdated" fills HDD

Sam Kuper sam.kuper at uclmail.net
Wed Feb 17 15:31:55 PST 2010

On 17 February 2010 22:38, Ryan Schmidt <ryandesign at macports.org> wrote:

> On Feb 17, 2010, at 08:59, Sam Kuper wrote:
> > I just ran "sudo port -f -p clean --all all", which completed OK as far
> as I can tell, and then "sudo port upgrade outdated". The latter command has
> got as far as "---> Building boost" but seems now to be stuck there and is
> now simply eating hard drive space. I had 3.03GB free hard disk space when I
> ran the command, and now, 20 minutes later, have only 1.09GB free and this
> is decreasing by 0.01GB every few seconds. Is this normal? If not, what am I
> doing wrong?
> Yes, this is normal. I was surprised by this too last time I upgraded
> boost, but boost seems to need about 5-6GB free hard drive space to build
> and install. After it's all built and installed, it occupies about 1.3GB.

OK, it hadn't occurred to me that I'd need an OS's worth of space just to
upgrade some C++ libraries. Now I know better. Thank you for clueing me in.

This sort of raises another issue. The MacPorts
Guide<http://guide.macports.org/>says, "The selfupdate option should
be used regularly..." Well, OK. But when
I run , I get the following message:

"The ports tree has been updated. To upgrade your installed ports, you
should run
  port upgrade outdated"

So this is what I did. And it turns out to have been a *really* expensive
operation: a *very* lengthy process that requires a *lot* of free HDD space.
It is too expensive an operation, for me at least, to run regularly.

So what's the solution?

For me at least, the solution will involve installing software via .dmg
files wherever possible, instead of via MacPorts. It will also involve
pruning as many unneeded ports as possible from my system. But I wonder,
isn't there some way that MacPorts could provide pre-built/compiled
software? I mean, it's not like Mac users are running on an especially
diverse range of hardware...

Sorry for the slightly OT rant, I'm just feeling a little worn out by all
this! (Much less worn out than I would have been without all the help I've
received from you and all the other good people on the mailing list,

> > PS. Before posting here, I sought help via the FAQ, the problems hotlist,
> a web search, the IRC channel, and the bug tracker. The latter wouldn't let
> me log in to file a new bug and the others didn't provide any apparently
> satisfactory solutions, so here I am on the mailing list!
> What error did you see when trying to log in to the issue tracker?

"Unknown username email or password"

I tried several times, and I'm pretty sure I typed the correct password.
Then I tried resetting the password via the "Lost password" form and
attempted to login with the new password that generated. This also resulted
in the message:

"Unknown username email or password".

Thanks for your help,

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.macosforge.org/pipermail/macports-users/attachments/20100217/417b6ada/attachment.html>

More information about the macports-users mailing list