error report when trying to install php/mamp

Joshua Root jmr at
Mon Jan 4 10:51:46 PST 2010

On 2010-1-5 05:30 , Ola Lundén wrote:
> Ok, so I've checked that the file "libinintl.dylib" exists, I've
> de/activate gettext and found the file. But I still get the same error
> message running my installation.

Looking at the command in your output again, it's missing
-L/opt/local/lib, which would certainly cause the failure. When I build,

/usr/bin/gcc-4.2  -o -fPIC -bundle -L/opt/local/lib
bindtextdomain.c -lintl

as opposed to your

/usr/bin/gcc-4.2  -o -fPIC -bundle bindtextdomain.c

> When I ran the "lipo -info" command it returned:
>     Non-fat file: /opt/local/lib/libintl.dylib is architecture: x86_64
> Which I guess is ok since I've got an MacBook Pro running Snow Leopard.

Did you upgrade to Snow Leopard from an earlier OS version? If so, did
you follow <>? I'm thinking your
perl might be the wrong arch or something.

> About the other dependencies that failed to build: libtool automake
> autoconf help2man libxml2 mhash, shouldn't the installation process take
> care of them as well? When should they have been installed?

After help2man. They were just blocked by it failing.

- Josh

More information about the macports-users mailing list