kile-devel port failed on Tiger

Joachim Osnabryg osna at
Fri Jan 29 07:11:59 PST 2010

Helo Experts,

Today I tried to install kile-devel with MacPorts on my intel Tiger. It  
ended with:

CMake Error: CMAKE_C_COMPILER not set, after EnableLanguage
CMake Error: CMAKE_CXX_COMPILER not set, after EnableLanguage
-- Configuring incomplete, errors occurred!

So I run it again for debugging with
$ sudo port -d install kile-devel

which ended with:

Warning: the following items did not execute (for automoc):  
org.macports.activate org.macports.configure  
org.macports.destroot org.macports.install
Error: The following dependencies failed to build:
(named many)
Error: Status 1 encountered during processing.

 From the terminal output I attach the beging and the last sixty lines (80  
lines from nearly 2000) which I suppose can tell you where the problem is.

=> Might kile-devel port not be applicable or buildable on Mac 10.4?

=> Is there a workarround for that?

=> If there is nothing reasonable to do arround it, how can I best get rid  
of the failed installation? Just with sudo port uninstall kile-devel?

What about the dependencies, intalled Cmake etc?

Any advice here? Has somebody successfully installed kile-devel or kile on  
OSX 10.4?

If someone find it useful I'm gladly disposed to sent the complete output.

Thanks in advance!

Mac BacicTeX 2009 - TeXShop 2.29 / TeXworks 0.2.3
LyX 1.6.5 - MacBook Pro intel OSX 10.4.11 Tiger

More information about the macports-users mailing list