kile-devel port failed on Tiger

Joshua Root jmr at
Fri Jan 29 07:30:35 PST 2010

On 2010-1-30 02:11 , Joachim Osnabryg wrote:
> Helo Experts,
> Today I tried to install kile-devel with MacPorts on my intel Tiger. It
> ended with:
> CMake Error: CMAKE_C_COMPILER not set, after EnableLanguage
> CMake Error: CMAKE_CXX_COMPILER not set, after EnableLanguage
> -- Configuring incomplete, errors occurred!
> So I run it again for debugging with
> $ sudo port -d install kile-devel
> which ended with:
> Warning: the following items did not execute (for automoc):
> org.macports.activate org.macports.configure
> org.macports.destroot org.macports.install
> Error: The following dependencies failed to build:
> (named many)
> Error: Status 1 encountered during processing.

You haven't included the most relevant part of the output. All I can
tell you that you don't already know is that it is actually automoc that
failed to build.

> => Might kile-devel port not be applicable or buildable on Mac 10.4?
> => Is there a workarround for that?

You can try to find out by searching Trac:

> => If there is nothing reasonable to do arround it, how can I best get
> rid of the failed installation? Just with sudo port uninstall kile-devel?

It hasn't been installed yet, so `sudo port clean --all kile-devel` is
all that's needed to get rid of the build dir and distfiles for kile-devel.

> What about the dependencies, intalled Cmake etc?

The port_cutleaves port might be useful to you.

- Josh

More information about the macports-users mailing list