Help W/ Manual Install of liblastfm

Hal Vaughan hal at
Sun Jun 13 14:01:13 PDT 2010


I've tried, many times, to get Amarok working on my iMac.  I spent about 10 years running a business based on my own software on Linux, so I'm used to Linux and still prefer some Linux programs to what I cat get on OS X.  However, I have a VERY limited experience with C or C++ or building packages, since that was something I didn't need to do.

In other words, I can usually follow technical directions, but don't have the background to make assumptions or to just "know" things that you'd know if you're working with gcc or build programs a lot.

A few days ago I decided to try again.  Instead of building Amarok as my first program, I started with KDE.  Even that failed, and I finally found out that I needed to start with Python26 (for some reason if I didn't install it first, other programs had issues along the way with files it might install).  Once I saw that, it was easy to get Python installed and, after that KDE.  I tested KDE (actually kde4) with kdegames4 and they're working fine.  (Actually, I first just installed "kde", but that gave me kde3, which Amorak wouldn't work with).

Current problem:

I have KDE4 working and I tried installing Amorak and it quit on liblastfm.  So I took the list of dependencies after liblastfm and installed them.  They're building now, while I'm writing this.  I Googled and found this on liblastfm:

So it's a bug on Snow Leopard, which I'm on.  It looks like there are instructions to do it by hand, which I'm okay with, but I want to check a few things.  Here's the instructions:

port -dv extract iblastfm

cd /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_audio_liblastfm/work/liblastfm-0.3.0

sh-3.2# cat .qmake.env

QMAKE_CC = /usr/bin/gcc-4.2 QMAKE_CXX = /usr/bin/g++-4.2 QMAKE_LFLAGS_RELEASE = -L/opt/local/lib -arch x86_64 -Xarch_x86_64 QMAKE_CFLAGS_RELEASE = -pipe -O2 -arch x86_64 -Xarch_x86_64 -I/opt/local/include QMAKE_CXXFLAGS_RELEASE = -pipe -O2 -arch x86_64 -Xarch_x86_64 -I/opt/local/include

I would think that first line should be "sudo port -dv extract liblastfm"  (added sudo and made it liblastfm instead of iblastfm).  Is that right?  Or instead of using sudo, doing an su before doing any of htis process.  I can do that, but am I right this has to be done with Admin permissions, like "port install $program" does?

And then I see the results for .qmake.env and what it should read, but then there's another note added:

QMAKE_CC = /usr/bin/gcc-4.2 QMAKE_CXX = /usr/bin/g++-4.2 
QMAKE_LFLAGS_RELEASE = -L/opt/local/lib -arch x86_64 -Xarch_x86_64 
QMAKE_CFLAGS_RELEASE = -pipe -O2 -arch x86_64 -Xarch_x86_64 -I/opt/local/include 
QMAKE_CXXFLAGS_RELEASE = -pipe -O2 -arch x86_64 -Xarch_x86_64 -I/opt/local/include 

It's the same as what "cat .qmake.env" would show, but only with carriage returns.  Is that the only difference?  And, basically, is all I need to do to make sure that's what's in .qmake.env?  If so, what do I do AFTER I've fixed the file?

Could someone provide a clearer idea of what I need to do in this process?

Thanks for any help on this!

Hal Vaughan

More information about the macports-users mailing list