Amorak Won't Install (How to Make It Install)

Hal Vaughan hal at
Sun Jun 13 22:29:42 PDT 2010

Here's a summary of what I had to do to make Amarok install on Snow Leopard:

First I ran "sudo port install amarok" and that installed a lot of the dependencies.  When done, there was an error for liblastfm.  I went on and used my mouse to cut and past a few lines.  I did another "sudo port install ${packages}" where ${packages} is a list of all the dependencies left, OTHER THAN liblastfm.  That went without incident.

So what we have now have all the dependencies, other than liblastfm, installed under MacPorts, we have to deal with the harder stuff.  Each step to fix something involves simply making some changes in a config file.  I'm still not sure why these are necessary, since all of them have been reported as bugs at least 4-5 months ago, but they are not fixed as of this writing.

First, fix liblastfm:

sudo port -dv extract liblastfm
sudo vi /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_audio_liblastfm/work/liblastfm-0.3.0/.qmake.env
(Yes, it's a one line command that email will split up.)

I found the following:

QMAKE_CC = /usr/bin/gcc-4.2 QMAKE_CXX = /usr/bin/g++-4.2 
QMAKE_LFLAGS_RELEASE = -L/opt/local/lib -arch x86_64
QMAKE_CFLAGS_RELEASE = -pipe -O2 -arch x86_64 -I/opt/local/include 
QMAKE_CXXFLAGS_RELEASE = -pipe -O2 -arch x86_64 -I/opt/local/include 

It's quite possible these could take up an extra line or two or be formatted like above.  Find these lines and add:

-Xarch_x86_64 after the -arch x86_64

The lines should now read like this:

QMAKE_CC = /usr/bin/gcc-4.2 QMAKE_CXX = /usr/bin/g++-4.2 
QMAKE_LFLAGS_RELEASE = -L/opt/local/lib -arch x86_64 -Xarch_x86_64 
QMAKE_CFLAGS_RELEASE = -pipe -O2 -arch x86_64 -Xarch_x86_64 -I/opt/local/include 
QMAKE_CXXFLAGS_RELEASE = -pipe -O2 -arch x86_64 -Xarch_x86_64 -I/opt/local/include 

And, of course, save the file.  (I tend to be pretty bad about that when I'm in a hurry.)

Then run:

sudo port install liblastfm

That will take care of that package.  Now we have all the dependencies in place for Amorak, which has TWO problems on its own.  Here's how to install Amarok:

sudo port -dv extract amarok
sudo vi /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_amarok/work/amarok-2.2.0/CMakeLists.txt

Comment out the lines that have something like this (then save it): 

	find_package( QtScriptQtBindings REQUIRED )
	macro_log_feature( QTSCRIPTQTBINDINGS_FOUND ...

sudo vi /opt/local/var/macports/sources/

Find this block:

post-destroot {
   # Place bundle icons in correct location
	system "mv ${destroot}${prefix}/bin/* ${destroot}${applications_dir}/KDE4/"
	system "rm -rf ${destroot}${prefix}/bin"

Comment out the two lines that start with "system" (and save it!).

Then we're finally ready:

sudo port install amarok

That should do it.

You can also check this page for a lot of info along the way with this:


And I found some of that and other info on the bug reporting pages for MacPorts: (liblastfm) (amarok, marked as duplicate for next link, but this helped me more) (amarok) (amarok, same as the other Amarok bug, but more in depth)

Now, here's the part that caught me by surprise: I noticed that the lines commented out did not move files to /Applications/MacPorts/KDE, so I assumed (yeah, make your jokes about that word and me now, go ahead!) that there would be no icon for Amorak in the Applications folder on my iMac, and searched for a binary to run.  I didn't find one, but did find that the icon IS there, in Applications/MacPorts/KDE, as it should be.

I have to add that after spending several hours on this and getting it working, it's a little frustrating.  I haven't been working on Linux for years and I guess I missed some important upgrades on Amorak and feel like it doesn't have all the functionality it used to have.  I don't think I had ever seen Amarok 2 before and I found some flakey behavior that I would classify as more expected of gamma software than even beta, but I also know they're developing it on Linux and that it takes a lot of work for them to get it working at all on OS X.  I had been using Songbird since I was on OS X, but that provides even less flexibility than the new Amorak, so this is an upgrade for me.


More information about the macports-users mailing list