Package build failures on 10.6.2 with +universal: gimp, advi, TeXShop and LaTeXiT

Russell Jones russell.jones at
Fri Mar 5 08:44:19 PST 2010

Hello all,


I'm trying to install a bunch of packages (list in packages.txt) and some of them are not building. I'm happy to file/search for bugs for these, but I wonder if someone could have a quick look and see if there's a common cause to  all of them. To keep this bit to a sane length, the details are attached in a zip file (2.6MB uncompressed).


The builds were preceded by sudo port selfupdate; sudo port upgrade outdated (none were) and each by sudo port clean <package>


I'm trying to install them on a 10.6.2 laptop, a MacBook Pro, but this will be used to make an image to be deployed to non-64-bit machines, so I need to build +universal. I've installed the latest Xcode, 3.2 (gcc 4.2.1 Apple build 5646). 


The gimp meta-package


gimp2 with no variants fails to build because it depends on py25-gtk which depends on python25 which fails to build on 10.6



I tried to build py26-gtk with the intention of building gimp2 hoping that it would use this instead of python 2.5 (is this possible?)


py26-numpy failed to build



I tried py26-numpy +noatlas which also fails to build



Continuing with gimp2 +no_python:


xsane fails to build



gimp-app fails to build



All other dependencies of the gimp meta-package are OK at the moment.


advi fails to build


See advi-debug.txt


TeXShop and LaTeXiT fail to build


See TeXShop-debug.txt and LaTeXiT-debug.txt



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Type: application/x-zip-compressed
Size: 133470 bytes
URL: <>

More information about the macports-users mailing list