New user, port selfupdate error

tome at QX.Net tome at QX.Net
Sat Mar 20 10:18:55 PDT 2010

First, I have just realized that I have been replying to the mailing list incorrectly.  The error occurred because I have been using the ffmpeg mailing list 
and when one replies to that list, the mailing list email address automatically goes in the To: box, at least on my system.  I have been replying directly 
to those that replyed to my needs, and not the mailing list.   My mistake, my apologies.

So, to Richard DeLaurell, thanks for your reply.  I meant -d, but typed -v.  Sorry!

Next, to Frank Schima, it seems I should not mention the 'other site', so hopefully you got my email with the requested information.

As background, I have been trying to install faac from a source download, and have not been able to get any help with the problem I have 
encountered. Continued web searching lead me to a mention of installing with 'the other site', which lead me to the 'other sites' web site. I then just 
followed the instructions. I will run port uninstall and then find the latest source and try that. As for your other question, which make? ==> 
/usr/local/bin/make I installed this ( 3.81 ) from a source download to replace 3.80, a requirement for installing ffmpeg      Thanks for your help! 

Now, to Ryan,

I followed Frank's guidance to install 1.8.2, which I have installed, over 1.7.  I initially thought about doing port uninstall for 1.7, but not 
knowing that I was dealing with two different 'port' sites, I decided that 1.8.2 fit in the update category and that uninstall should not be necessary.  
Was that a mistake?   port version shows 1.8.2, and it seemed to run once I got the make binary in it's path.

My problem now is that I received an Error when I tried     sudo port install faac       which I then reexecuted with the -d flag and saved the output.  It is 
unclear whether I should go directly to the <> or put the Error on this mailing list?  I will list the Error in 
this email, but if I should go to the bug site, I will do that also.      The Error:

Usage: /usr/libexec/gcc/powerpc-apple-darwin8/4.0.1/libtool -dynamic [-] file [...] [-filelist listfile[,dirname]] [-arch_only arch] [-o output] [-
install_name name] [-compatibility_version #] [-current_version #] [-seg1addr 0x#] [-segs_read_only_addr 0x#] [-segs_read_write_addr 0x#] [-
seg_addr_table <filename>] [-seg_addr_table_filename <file_system_path>] [-all_load] [-noall_load]
make: *** [] Error 1
Error: Target returned: shell command " cd 
"/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_mp4v2/work/mp4v2-1.9.1" && 
/opt/local/bin/make -j1 all " returned error 2
DEBUG: Backtrace: shell command " cd 
"/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_mp4v2/work/mp4v2-1.9.1" && 
/opt/local/bin/make -j1 all " returned error 2
    while executing
"command_exec build"
    (procedure "portbuild::build_main" line 9)
    invoked from within
"$procedure $targetname"
Warning: the following items did not execute (for mp4v2): org.macports.activate org.macports.destroot org.macports.install
Error: The following dependencies failed to build: mp4v2
Error: Status 1 encountered during processing.
To report a bug, see <>

My thanks to everybody for your support!!!!


------- Original Message -------
>From    : Ryan Schmidt[mailto:ryandesign at]
Sent    : 3/20/2010 4:09:57 AM
To      : tome at
Cc      : macports-users at
Subject : RE: Re: New user, port selfupdate error

 On Mar 19, 2010, at 17:15, tome at QX.Net wrote:

> I am attempting to use macports for the first time.  I am not a computer science person, but do have limited experience with gcc and 
> installations.  I installed macports 1.7 from a disk image, with a successful completion message.  I then tried the second step of
> % sudo port -v selfupdate
> receiving the error shown in the below partial terminal output.
> My system is Mac PowerPC 750 ( pismo ) running OS X 10.4.11.
> Darwin Kernel Version 8.11.0
> Xcode 2.5
> gcc 4.0.1
> GNU make 3.81
> -----------------------------
> I have also tried the following, with the current port version 1.7, and received the indicated Error:
> % cd /opt/local/bin/portslocation/dports/faac
> % sudo port install faac
> Password:
> Error: Unable to execute port: invalid command name "livecheck.type"

The command "livecheck.type" is only available in MacPorts 1.8 and later. "sudo port selfupdate" should have updated you to the latest version of 
MacPorts, 1.8.2, unless rsync does not work on your network, in which case you need to manually install MacPorts 1.8.2 from the MacPorts 1.8.2 for 
Tiger disk image.

Wherever you were looking that suggested 1.7 is the current version is in error. Please check the only official source of information about MacPorts: the 
MacPorts web site at  .

P.S: I can guess what site you were looking at that mentioned version 1.7, but I'm not going to mention the site here because I don't want to give it any 
more traffic. That site is not affiliated with the MacPorts project in any way and you should not refer to it for any information about MacPorts, nor 
donate any money to its operator. For more information, you can see: 

More information about the macports-users mailing list