Gramps version 3.2.0 for Mac OS X

Tim Lyons guy.linton at
Mon Mar 29 03:17:06 PDT 2010

On 29 Mar 2010, at 06:17, Ryan Schmidt wrote:

> On Mar 28, 2010, at 12:10, Tim Lyons wrote:
>> (1) If you had a previous installation of Gramps, you have to  
>> rename/move aside /Applications/MacPorts when you do a fresh install.
> Why was this necessary? At most, you should have to "sudo port  
> deactivate gramps" to move the old one aside, then "sudo port  
> install gramps" to install the new one; I would never expect the  
> user to need to manually fiddle with anything in /Applications/ 
> MacPorts. Ideally, deactivating the old version would not be  
> necessary either, but I did not test upgrading.
"Fresh install" is probably not a precise enough description of what  
I meant.

I deleted /opt to ensure that I had a really fresh start, then  
installed a fresh copy of MacPorts. When Macports ran, it found the / 
Applications/MacPorts directory and reported that this was unexpected  
because it had no record of it, and then failed with the message:
Error: Target org.macports.activate returned: Image error: / 
Applications/MacPorts/Python 2.6/Build  
already exists and does not belong to a registered port.  Unable to  
activate port python26.

Prior to this, I had tried upgrading, but got into a real mess for  
reasons that you don't want to know about.

Anyway, I thought starting from a fresh copy of MacPorts would be a  
good idea because (1) I probably had lots of components that were no  
longer needed by Gramps, and I didn't want to keep upgrading them  
forever. (2) Wouldn't starting from a fresh be the only way to really  
check that the dependencies were correct. When I first started using  
MacPorts way back in March 2008, I seem to remember that some of the  
dependencies in some components were not quite right, and you needed  
to build something explicitly before building something else. I am  
happy to say that when I did the complete build, I had absolutely no  
problems whatsoever!

>> (2) MacPorts ticket 24127 (,  
>> libproxy 0.4.0 build failure - I loaded the portfile for 0.3.0  
>> which worked OK.
> I fixed this.
Thanks, but I see that the new libproxy still doesn't work on Tiger,  
which is where I am at the moment! (Ryan has reported this on  
libproxy ticket 104)

>> (4) The spelling checker is not installed because there is no  
>> MacPort of the python bindings to gtkspell, this results in the  
>> warning: "14484: WARNING: line 66: Spelling checker is  
>> not installed".
> I'm not familiar with gramps, but a quick check (new family  
> history, new person, notes field) showed on-the-fly spell checking  
> working already, on Snow Leopard. This is after upgrading gramps to  
> use python 2.6. With python 2.5 I was seeing that warning too; with  
> 2.6 not anymore, so maybe using 2.6 has somehow automatically fixed  
> this. (Or maybe I've got some py26 module installed that's helping  
> here.)
I think the problem is the python binding to gtkspell (actually  
gtkspell2). I think that gnome-python-extras is only building the  
python module for gtkspell if gtkspell is present when gnome-python- 
extras is built. I.e. it all depends of the order of building. I have  
had spell checking working for me before, but not now. I have raised  
a ticket against this.

More information about the macports-users mailing list