launching gnome fails

Pau vim.unix at
Wed Mar 31 04:37:19 PDT 2010


after the problem with fvwm, I have now tried to install gnome.

I installed the metapackage and everything ran smooth. Then I follow
the indications here:

But I get a window protesting:

"There is a problem with the configuration server:
(/opt/local/libexec/gconf-sanity-check-2 exited with status 2)"

And then

"Could not connect to session bus: Not enough memory"


"Could not acuire name on session bus"

I have tried launching the dbus-launch gnome-session, but that makes X
start (I am running full-screen) and after a second it closes.

This is my script:

gumby% cat ~/.xinitrc.d/
# make the freedesktop menu entries work
export XDG_DATA_DIRS=/opt/local/share
export XDG_DATA_HOME=/opt/local/share
export XDG_CONFIG_DIRS=/opt/local/etc/xdg

# enable sound
export ESPEAKER=localhost

# use GNOME's window manager
#exec quartz-wm &

exec metacity &

# start GNOME
exec /opt/local/bin/gnome-session
#exec /opt/local/bin/dbus-launch /opt/local/bin/gnome-session

More information about the macports-users mailing list