p5-locale-gettext: gettext function not found (was: Re: Gettext error prevents update)

Ryan Schmidt ryandesign at macports.org
Sun May 9 15:43:16 PDT 2010

On May 9, 2010, at 12:21, Scott Haneda wrote:

> On May 9, 2010, at 4:06 AM, notbot wrote:
>> Computing dependencies for p5-locale-gettext 
>> Configuring p5-locale-gettext 
>> Error: Target org.macports.configure returned: configure failure: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_perl_p5-locale-gettext/work/gettext-1.05" && /opt/local/bin/perl Makefile.PL INSTALLDIRS=vendor " returned error 2 
>> Command output: checking for gettext... no 
>> checking for gettext in -I/opt/local/include -arch x86_64 -L/opt/local/lib -lintl...gettext function not found. Please install libintl at Makefile.PL line 18. 
>> no 
>> Error: Unable to upgrade port: 1 
>> I have tried updating MacPorts, but still get same error.
> It looks like this is nearly identical to your issue: http://cpanforum.com/threads/12249

So is this:


(p5-locale-gettext can't find gettext library)

And this seems closely related:


(p5-locale-gettext can't find gettext header)

We've had these problems reported several times but I have never understood why it's failing to build for a few select users when it builds fine for everybody else.

We could try the solution suggested in the cpanforum thread, only why does it build for most users already without that change?

notbot, can you provide more info? What version of Xcode do you have? Do you have anything installed in /usr/local or /sw? Is your gettext port installed universal, and if so for what architectures? Anything else you can think of that might make your system different from others?

More information about the macports-users mailing list