Gettext error prevents update

Scott Haneda talklists at
Sun May 9 10:21:19 PDT 2010

On May 9, 2010, at 4:06 AM, notbot <anotbot at> wrote:

> Computing dependencies for p5-locale-gettext
> Configuring p5-locale-gettext
> Error: Target org.macports.configure returned: configure failure:  
> shell command " cd "/opt/local/var/macports/build/ 
> _opt_local_var_macports_sources_rsync.macports.org_release_ports_perl_p5- 
> locale-gettext/work/gettext-1.05" && /opt/local/bin/perl Makefile.PL  
> INSTALLDIRS=vendor " returned error 2
> Command output: checking for gettext... no
> checking for gettext in -I/opt/local/include -arch x86_64 -L/opt/ 
> local/lib -lintl...gettext function not found. Please install  
> libintl at Makefile.PL line 18.
> no
> Error: Unable to upgrade port: 1
> I have tried updating MacPorts, but still get same error.

It looks like this is nearly identical to your issue:

Hopefully you can find a MacPorts trac ticket with a patch or  
solution. If not, maybe the above link will allow you to patch on your  
own. Definately search trac, or google limited to trac.

As more MacPorts users get online, I'm certain someone will know a  
better solution. Today may be a little slow with it being mothers day.

Scott * If you contact me off list replace talklists@ with scott@ *  
(Sent from a mobile device) 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list