error building Octave in parallel

Ryan Schmidt ryandesign at
Tue May 11 23:38:30 PDT 2010

On May 11, 2010, at 20:28, Liam Groener wrote:

> I tried to build Octave 3.2.4 on an Mac OS X 10.6.3 machine. As I had Octave 3.2.3 already installed, I uninstalled it before attempting to install 3.2.4.

Ok. For future reference, for most ports, it's not usually necessary; usually you can just upgrade a port in place, i.e.

sudo port upgrade octave

I don't know whether octave is an exception to this rule or not.

> During the attempted install, I got the following messages:
> iMac-4718:~ liamg$ sudo port install octave
> --->  Computing dependencies for octave
> --->  Fetching octave
> --->  Verifying checksum(s) for octave
> --->  Extracting octave
> --->  Applying patches to octave
> --->  Configuring octave
> --->  Building octave
> Error: Target returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_math_octave/work/octave-3.2.3" && /usr/bin/make -j5 all " returned error 2
> Command output: cross references, insertions,
> (/opt/local/share/texmf-dist/tex/generic/epsf/epsf.tex
> This is `epsf.tex' v2.7.3 <23 July 2005>
> ) localization, formatting, and turning on texinfo input format.)
> (./octave-a4.aux
> ./octave.aux:4743: TeX capacity exceeded, sorry [save size=5000].
> @otherbackslash ->@let \=@realbackslash 
> @xrdef #1#2->{@indexnofonts @turnoffactive 
>                                           @xdef @safexrefname {#1}}@expanda...
> l.4743 @xrdef{doc-setpwent-pg}{555}
> ./octave.aux:4743:  ==> Fatal error occurred, no output PDF file produced!
> Transcript written on octave.log.
> /opt/local/bin/texi2dvi: pdfetex exited with bad status, quitting.
> make[3]: [octave.pdf] Error 1 (ignored)
> ./octave-a4.aux:4743: TeX capacity exceeded, sorry [save size=5000].
> @otherbackslash ->@let \=@realbackslash 
> @xrdef #1#2->{@indexnofonts @turnoffactive 
>                                           @xdef @safexrefname {#1}}@expanda...
> l.4743 ...etgrnam-title}{Group Database Functions}
> ./octave-a4.aux:4743:  ==> Fatal error occurred, no output PDF file produced!
> Transcript written on octave-a4.log.
> /opt/local/bin/texi2dvi: pdfetex exited with bad status, quitting.
> make[3]: [octave-a4.pdf] Error 1 (ignored)
> make[1]: *** [doc] Error 2
> make: *** [all] Error 2

I usually don't have trouble building octave, but I also usually build with either 2 or 1 build make jobs, and I see (from "make -j5" in your output) that you're using 5. I tried just now with 5 make jobs (on my 2-core MacBook Pro) and got the same error. So we need to disable parallel building in this port until the developers of the software fix this bug. (And someone should report the bug to them.)

To work around this for now, build with fewer build make jobs, i.e.

sudo port clean octave
sudo port install octave

> Error: Status 1 encountered during processing.
> Before reporting a bug, first run the command again with the -d flag to get complete output.

This was advising you to run the same command again that you ran before, but inserting the -d flag at the appropriate place within that command to get more detailed information that will help us diagnose the problem.

> iMac-4718:~ liamg$ octave -d
> /Users/liamg/bin/octave: line 3: /opt/local/bin/octave-3.2.3: No such file or directory
> iMac-4718:~ liamg$ sudo install octave -d
> Password:
> install: octave: Inappropriate file type or format
> My Unix is weak and I don't know what to do next?

The command you ran before was "sudo port install octave" and the correct place for the "-d" flag is immediately after the word "port". So the new command if you wanted to get debug output would be "sudo port -d install octave". But there's no need for it now since I was able to reproduce the problem already.

More information about the macports-users mailing list