Error: port activate failed: Registry error: No port of e installed.

David Gentry localbusinesswebsites at
Mon Oct 11 10:21:30 PDT 2010

I am glad I signed up for this email list last week because one post made me think that maybe I am not crazy.  The post said that a port "disappeared."  Well, I have had 3 ports "disappear."

Here is the sequence of events:

1. Last week, I installed Macports.

2. Per the documentation, I ran "port selfupdate."

3. I noticed that I could not connect to TCP ports 80, 3306, and 8500 from an "http" browser address -- all ports that are necessary for the shopping cart application I am developing.  I got a browser message, "Unable to connect to server," both from Firefox and Safari.  I am dead in the water.  Before I installed Macports, I could readily connect to my embedded Apache2 server on my Mac by entering my computer's IP address or IP address address and port number on a browser address line.

4. I checked my Mac firewall and permissions to see if they presented a problem that may account for my failure to connect to my Apache2 server.  I could detect no problem with my firewall or permissions.

5. I used Mac's Network Utility to run a Port Scan for my computer's IP address.  Much to my amazement, the result was that my three TCP ports -- 80, 3306, and 8500 -- are not open!

6. In my terminal window, I ran a command to list all inactive ports.  I picked several to run a "port activate" command on.  For example, I said, "port activate [apache2]" and "port activate [mysql5]."  I received the error message in the subject line of this email.

What should I do now?  I need my ports back!

I have a couple of thoughts:

1. I could run a command to determine if the ports I need are even installed.  If not, I could run an install command.

2. I could use Mac's Time Machine backup to restore my system to the way it was the day before I installed Macports.

Any other suggestions? 

More information about the macports-users mailing list