=?utf-8?Q?Re=3A_llvm=3A_?=clang not included in 2.8?

Takashi Yoshida takashi at takashiyoshida.org
Tue Oct 12 17:02:59 PDT 2010

        That's strange. I just tried `which clang` and it came back with '/opt/local/bin/clang'. I also tried running `port contents llvm` and it listed '/opt/local/bin/clang' among other things as well.I had older clang installed from version 2.6_2 and 2.7_2 and recently upgraded it to 2.8_0.Here's what I get when I run:`port installed | grep llvm`  llvm @2.6_2  llvm @2.7_2  llvm @2.8_0+clang (active)
        Strange part is that older versions do not have any variants listed (+clang) and when I upgraded to version 2.8, it appears like it picked up clang variant (which is not listed if you run `port info llvm`) automatically.You can try installing the older version of llvm but you may also want to hear from the maintainers first.
        -- Takashi YoshidaSent with Sparrow
        On Wednesday, October 13, 2010 at 5:12 AM, Boris Dušek wrote:
            Hello,I installed the llvm port with version 2.8, but `clang' command is notincluded. I don't know if it was ever included in previous versions. There isno variant of llvm that would indicate turning clang on, neither is there aport with name clang. Is there any way to get clang from this or another port?Best regards,Boris Dušek_______________________________________________macports-users mailing listmacports-users at lists.macosforge.orghttp://lists.macosforge.org/mailman/listinfo.cgi/macports-users

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.macosforge.org/pipermail/macports-users/attachments/20101013/f04966c5/attachment.html>

More information about the macports-users mailing list