Error: port activate failed: Registry error: No port of e installed.

David Gentry localbusinesswebsites at
Wed Oct 13 11:16:50 PDT 2010

Dear Ryan Schmidt, John B Brown, and Rainer Muller,

Thank you all so much.  I used Disk Utility to verify and then repair permissions.  Then I executed "sudo port install apache2."  I got "sudo: /var/db/sudo writable by non-owner (040775), should be mode 0700."  After several tries, I corrected the ownership issue, and the "sudo port install apache2" command installed and activated apache2!  I had almost given up which would mean that I would abandon building my application.

Now, all I need to do is install mysql5 and whatever other ports are required to use ports 80, 8500, and 3306.

Thanks, again.


On Oct 13, 2010, at 6:39 AM, Ryan Schmidt wrote:

On Oct 12, 2010, at 18:34, dgentry at wrote:

> I installed Xcode successfully.
> When I ran "sudo port install apache2," I got:
> "sudo: /etc/sudoers is mode 0666, should be 0440
> Segmentation fault"

I wonder why your sudoers has the wrong permissions. It certainly needs to be corrected.

> I googled that result and then I ran "chmod 0440 /etc/sudoers."  The result was:
> "chmod: Unable to change file mode on /etc/sudoers: Operation not permitted."

You need root permission to change the permissions of the sudoers file. Ordinarily that would mean run "sudo chmod 0440 /etc/sudoers" but in this cas your sudo command doesn't work because the sudoers file has the wrong permissions. Catch 22.

If using Disk Utility's Repair Permissions command does not repair the permissions of /etc/sudoers you may have to "su root" and do it there. This means you'd need to enable your root account, which is not generally recommended, and you should disable the root account again afterward. Or you could change the permissions while booted to single user mode. These are rather advanced topics.

> I ran "port install apache2" and, quoting just the last several lines, I got:
> "--->  Staging apache2 into destroot
> Error: Target org.macports.destroot returned: shell command failed
> Log for apache2 is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_apache2/main.log
> Error: Status 1 encountered during processing.
> To report a bug, see <>"

I expect this too will have failed because you did not have sufficient privileges and needed to have used "sudo port install apache2", except that your sudo command is broken because of the permissions on the /etc/sudoers file.

macports-users mailing list
macports-users at

David J. Gentry
Good Things -- Small Packages, LLC
dgentry at

More information about the macports-users mailing list