unresponsive terminal after installing Macports Python PIL

John Stoner johnstoner2 at gmail.com
Thu Apr 28 16:21:31 PDT 2011

On Thu, Apr 28, 2011 at 5:22 PM, Ryan Schmidt <ryandesign at macports.org>wrote:

> On Apr 28, 2011, at 15:43, John Stoner wrote:
> > I run a macbook, with Snow Leopard. (10.6.6).
> >
> > I ran this command last night before bed:
> >
> > port install py26-pil +universal
> >
> > I wanted to install the python 2.6 version of the Python Imaging Library
> (py26-pil). It took a long time, but I think I was successful.
> >
> > However, after restarting my terminal application the next day, I got an
> unresponsive window: a cursor, with no prompt, and no command output. I type
> 'ls' and the cursor returns to the left of the screen, with no output.
> >
> > I put echo statements in my bash_profile and bashrc files, with no
> output, so I guess they were not called. After rebooting, my shell is
> normally responsive again, but I thought maybe someone with macports should
> know about this.
> Rebooting your computer is almost never necessary. I imagine you'd've
> gotten the same result (properly functioning terminal) by closing the
> nonfunctional terminal window and making a new one (Shell menu: New Window).
> I use the terminal a lot, making dozens of terminal windows over the course
> of a day, and several times a day I get a nonfunctional terminal window as
> you describe, particularly if I've just closed another terminal window a
> second ago. I don't remember this happening before upgrading from Tiger to
> Snow Leopard. I don't know what causes it but it doesn't overly concern me;
> I just make another window and move on. I doubt it has anything to do with
> MacPorts.
> Nope.

It's never happened to me before today, and I've used Snow Leopard for
months. Starting new windows didn't fix it. Killing the terminal app didn't
fix it. Switching to a different terminal app (iTerm) didn't fix it.
Rebooting did.

I don't know whether it has anything to do with Macports, really. I use
Macports once in a great while. This might be the first time since I
upgraded to Snow Leopard. I used it last night, and this happened. If it
happens to you several times a day and you use MacPorts a lot, maybe it is

'In knowledge is power; in  wisdom, humility.'
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.macosforge.org/pipermail/macports-users/attachments/20110428/a48660ad/attachment.html>

More information about the macports-users mailing list