unresponsive terminal after installing Macports Python PIL

Ryan Schmidt ryandesign at macports.org
Thu Apr 28 15:22:02 PDT 2011

On Apr 28, 2011, at 15:43, John Stoner wrote:

> I run a macbook, with Snow Leopard. (10.6.6).
> I ran this command last night before bed:
> port install py26-pil +universal
> I wanted to install the python 2.6 version of the Python Imaging Library (py26-pil). It took a long time, but I think I was successful. 
> However, after restarting my terminal application the next day, I got an unresponsive window: a cursor, with no prompt, and no command output. I type 'ls' and the cursor returns to the left of the screen, with no output. 
> I put echo statements in my bash_profile and bashrc files, with no output, so I guess they were not called. After rebooting, my shell is normally responsive again, but I thought maybe someone with macports should know about this.

Rebooting your computer is almost never necessary. I imagine you'd've gotten the same result (properly functioning terminal) by closing the nonfunctional terminal window and making a new one (Shell menu: New Window). I use the terminal a lot, making dozens of terminal windows over the course of a day, and several times a day I get a nonfunctional terminal window as you describe, particularly if I've just closed another terminal window a second ago. I don't remember this happening before upgrading from Tiger to Snow Leopard. I don't know what causes it but it doesn't overly concern me; I just make another window and move on. I doubt it has anything to do with MacPorts.

More information about the macports-users mailing list