port selfupdate fails

Andrew Long andrew.long at yahoo.com
Tue Aug 16 13:14:15 PDT 2011

> On 15 Aug 2011, at 21:12, Ryan Schmidt wrote:
>> On Aug 15, 2011, at 13:36, Andrew Long wrote:
>>> On 15 Aug 2011, at 18:52, Daniel J. Luke wrote:
>> <snip/>
>> The perl5 portgroup was just hours ago converted into a new unified format which is probably going to cause some issues for a few moments while things settle down. Things should be better in a few hours, or tomorrow.
> I'll do that tomorrow

Did that. The Perl upgrade has worked, but I'm still having problems with the Mono (see below)

>> For the other issue, please delete /Library/Frameworks/Mono.framework. You don't need to install the MacPorts mono ports unless you have a need for them; MacPorts isn't going to use them.

I left ports trying to build mono last night, and twenty four hours later, it was still building mono. There was a process running the /Library/Frameworks/mono.framework that was consuming an awful lot of mill. I killed and and cleaned mono, then got a new version of the mono framework from the mono web site, and tried to do the self-update again. No Joy.

I note a comment at the web site that the current release of mono for OSX is 32-bit only, and I'd need to build a 64-bit one myself. Haven't found the destructions for that yet. I'm going to try deleting the mono framework and having another go at the selfupdate.

Regards, Andy

Andrew Long
andrew dot long at yahoo dot com

-------------- next part --------------
A non-text attachment was scrubbed...
Name: PGP.sig
Type: application/pgp-signature
Size: 275 bytes
Desc: This is a digitally signed message part
URL: <http://lists.macosforge.org/pipermail/macports-users/attachments/20110816/9f5911b6/attachment.bin>

More information about the macports-users mailing list