disk I/O error (10) while executing query: ATTACH DATABASE '/opt/local/var/macports/registry/registry.db' AS registry

Rainer Müller raimue at macports.org
Mon Aug 22 08:30:35 PDT 2011

On 2011-08-19 21:26 , Ryan Schmidt wrote:
> On Aug 19, 2011, at 13:58, Jeremy Lavergne wrote:
>>> I do not believe I have any disk problem. Disk Utility shows no problem. I
>>> am able to copy the registry file just fine without any I/O errors.
>> That is an SQLite-specific error message, and not the foreboding of the
>> kernel.
> It took Google to remind me that I ran into the same problem last year, and Rainer was kind enough to provide the solution at that time, which worked again this time:
> http://lists.macosforge.org/pipermail/macports-users/2010-July/021051.html
> The solution is to do something with MacPorts with sudo again. This cleans up the database.

I enabled extended status codes in r82949 which are supposed to give
more details especially about I/O errors [1]. This change is only on
trunk at the moment.

As sqlite usually is quite robust I wasn't able to reproduce a corrupted
database in an easy way so I don't know if that really changes the output.


[1] http://www.sqlite.org/capi3ref.html#SQLITE_BUSY_RECOVERY

More information about the macports-users mailing list