Installed macports what to do next

james collins james.collins75 at
Thu Aug 25 13:48:51 PDT 2011

Sent from my iPhone

On Aug 25, 2011, at 3:49 PM, "Daniel J. Luke" <dluke at> wrote:

> On Aug 25, 2011, at 2:53 PM, james collins wrote:
>> I used subversion to get the ports tree.
> So you followed the instructions on the wiki and now 'port sync' works?

I followed the instructions. Just re-ran the sync command no errors. My computer returned all 0's i.e.

Total number of ports parsed: 0
Ports successfully parsed: 0

>> Rsync isn't working and I don't know why? The first time I got macports it worked?
> It's something local to your network setup (or your ISP).
>> I synced via the files I got through subversion. But selfupdate doesn't work, failing because of rsync. I have edited my sources.conf file.
> If rsync won't work, you probably can't use 'selfupdate' but if you configure for subversion, you can use 'port sync' to update your portfiles (and you can install a new macports version via the package on the website when there is a new release).
>> So I am trying to figure out why rsync isn't working. I have run selfupdate with the -v -d flags and I can put in my terminal output.
> That would probably be necessary for anyone to assist you, but it's most likely a firewall that you have setup to block rsync.

Here is what I got from terminal:

sudo port -v selfupdate 

----> Updating MacPorts base sources using rsync
rsync: failed to connect to Operation timed out (60)
rsync error: error in socket IO (code 10) at /SourceCache/rsync/rsync-42/rsync/clientserver.c(105)
shell command "/usr/bin/rsync -rtzv --delete-after rsync:// /opt/local/var/macports/sources/" returned error 10
Error: /opt/local/bin/port: port selfupdate failed: Error synchronizing MacPorts sources: shell command failed (see log for details)

And when I ran

sudo port -d selfupdate

The same as above with-

DEBUG: MacPorts sources location: /opt/local/var/macports/sources/
DEBUG: Error synchronizing MacPorts sources: shell command failed (see log for details) while executing "macports::selfupdate [array get global_options] base_updated"

Where can I find the log file on my computer?
>> Why can't my macports find the recoll port? I have found recoll on my computer from the sources from the port tree?
> You didn't say that you followed the instructions exactly (
> You need to do all three steps (checkout, configure your sources.conf, and run port -d sync)

I believe I followed the instructions to the tea.
>> Just curious, I know rsync would still fail but shouldn't macports find recoll?
> yes, if you configured it correctly, it would find it.

I have used the search command like

Port search recoll with no luck
> --
> Daniel J. Luke                                                                   
> +========================================================+
> | *---------------- dluke at ----------------* |                          
> | *-------------- -------------* |                          
> +========================================================+
> |   Opinions expressed are mine and do not necessarily   |                          
> |          reflect the opinions of my employer.          |                          
> +========================================================+

More information about the macports-users mailing list