Running meld (dbus error: autolaunch requested but X11 support not compiled)

iulian dragos jaguarul at
Thu Feb 3 07:26:17 PST 2011

On Thu, Feb 3, 2011 at 3:21 AM, Ionut Georgescu <ionutg at> wrote:
> Hi Iulian,
> enable /Library/LaunchDaemons/org.freedesktop.dbus-system.plist and
> respectively /Library/LaunchAgents/org.freedesktop.dbus-session.plist and
> then modify your ~/.profile or ~/.bash_profile
> Then restart the system. Open a terminal and type meld. It may crash the
> first time, but run it one more time and it will be ok.

Ionut, thanks a million! It works. I had to restart indeed (first I
tried without restarting and it failed with a connection refused
error). Now it works just fine (in the meantime, I also recompiled
dbus with X support, by changing the portfile locally. I don't know if
that is required or not).

I wonder if this should be part of the port file? It's definitely not
obvious, and Googling the internet didn't reveal anything.

> By the way, if you find another trustworthy merge tool please let know.

I used Meld for a long time on Linux. Before that I was using Araxis
Merge on Windows. They have a version for Mac OS, but I find it too
expensive and meld is just as good.

thanks again, you really made my day,

> Good luck,
> Ionut
> --
> "UNIX is basically a simple operating system, but you have to be a genius to
> understand the simplicity."
> _______________________________________________
> macports-users mailing list
> macports-users at

« Je déteste la montagne, ça cache le paysage »
Alphonse Allais

More information about the macports-users mailing list