port install doesn't create symlink

Jim Anderson jander at jandernet.com
Sat Nov 5 15:43:27 PDT 2011

That worked, but now when I enter "cpan", a binary in the perl5.14 dist, I get

jim-andersons-macbook-pro:~ jander$ cpan
-bash: /usr/local/bin/cpan: /usr/local/bin/perl: bad interpreter: No such file or directory

Why is it looking on /usr/local and not in /opt/local?

On Nov 5, 2011, at 5:18 PM, Brandon Allbery wrote:

> On Sat, Nov 5, 2011 at 17:12, Jim Anderson <jander at jandernet.com> wrote:
> I installed perl5.14 and expected that when I ran "perl -v" I'd see something like
>        This is perl 5, version 14, subversion 1 (v5.14.1) built for darwin-multi-2level
> But instead I see
>        -bash: /opt/local/bin/perl: No such file or directory
> "sudo port install perl5 +perl5_14"
> -- 
> brandon s allbery                                      allbery.b at gmail.com
> wandering unix systems administrator (available)     (412) 475-9364 vm/sms

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.macosforge.org/pipermail/macports-users/attachments/20111105/f95abe56/attachment.html>

More information about the macports-users mailing list