MyPaint install errors

bunk3m bunk3m at
Mon Nov 28 17:08:24 PST 2011

I've been trying to install MyPaint.  I've done selfupdate etc. a few times.

A few days ago when I tried Macports tried to install v0.9.1.  I gave up
because it failed and I saw that there is a bug/update on the tracker
that indicated Macports was supposed to install v1.0.  I did a clean and
waited until today.

Today I tried again. Now it recognizes and tries to install v1.0.0.  But
it still fails during the build.

Now it says it wants py2.6 numpy.  But I also think that it should be
installing py2.7 numpy if you have Python 2.7 installed.  I have 2.7
installed.  There is another diff listed on the tracker that says it
should be building for python2.7.

So how do I force this to use my already installed Python 2.7 instead of

And, how do I get MyPaint 1.0.0 to install all the dependencies (ie. numpy)?

I'm on OSX 10.6.8 with Macports 2.0.3

The command I used was: sudo port install mypaint

Thanks in advance for your help.

Here is the relevant portion of the error log.

---snip error log---
:notice:build --->  Building mypaint
:debug:build Executing (mypaint)
:debug:build Environment: CPATH='/opt/local/include'
:debug:build Assembled command: 'cd
&& scons -j2 prefix=/opt/local'
:debug:build Executing command line:  cd
&& scons -j2 prefix=/opt/local
:info:build scons: Reading SConscript files ...
:info:build Building for python2.6
:info:build You need to have numpy installed.
:info:build ImportError: No module named numpy:
:info:build   File
line 16:
:info:build     import numpy
:info:build shell command " cd
&& scons -j2 prefix=/opt/local " returned error 2
:error:build Target returned: shell command failed
(see log for details)
:debug:build Backtrace: shell command failed (see log for details)
    while executing
"command_exec build"
    (procedure "portbuild::build_main" line 8)
    invoked from within
"$procedure $targetname"
:info:build Warning: the following items did not execute (for mypaint):
org.macports.activate org.macports.destroot
:notice:build Log for mypaint is at:
---end log---

More information about the macports-users mailing list