sudo port selfupdate fails

Ryan Schmidt ryandesign at
Mon Sep 5 21:48:42 PDT 2011

On Sep 5, 2011, at 23:40, Johannes Ruscheinski wrote:

> Hi Ryan,
> After doing a "sudo port uninstall mono" I still get the same error.
> My build still prints out:
> base32cmd.o sha1cmd.o curl.o rmd160cmd.o sha256cmd.o readline.o uid.o
> tracelib.o tty.o readdir.o pipe.o flock.o system.o mktemp.o realpath.o
> -o Pextlib.dylib
> -L/System/Library/Frameworks/Tcl.framework/Versions/8.5 -ltclstub8.5
> -lcurl  -lreadline
> ===> making all in src/registry2.0
> /usr/bin/llvm-gcc-4.2 -c -DUSE_TCL_STUBS -DTCL_NO_DEPRECATED -g -O2 -W
> -Wall -pedantic
> -I/Library/Frameworks/Mono.framework/Versions/2.2/include
> -DHAVE_CONFIG_H -I.. -I.  -I"/usr/include" -fno-common registry.c -o
> registry.o
> In file included from ../cregistry/registry.h:35,
>                 from registry.c:39:
> How can I identify the problematic port in order to uninstall it?   Thanks!

It is not a port. It is a standalone installation of Mono, installed by a means other than MacPorts.

More information about the macports-users mailing list