sudo port selfupdate fails

Johannes Ruscheinski ruschein at
Tue Sep 6 06:41:58 PDT 2011

On 5 September 2011 21:48, Ryan Schmidt <ryandesign at> wrote:
> On Sep 5, 2011, at 23:40, Johannes Ruscheinski wrote:
>> Hi Ryan,
>> After doing a "sudo port uninstall mono" I still get the same error.
>> My build still prints out:
>> base32cmd.o sha1cmd.o curl.o rmd160cmd.o sha256cmd.o readline.o uid.o
>> tracelib.o tty.o readdir.o pipe.o flock.o system.o mktemp.o realpath.o
>> -o Pextlib.dylib
>> -L/System/Library/Frameworks/Tcl.framework/Versions/8.5 -ltclstub8.5
>> -lcurl  -lreadline
>> ===> making all in src/registry2.0
>> /usr/bin/llvm-gcc-4.2 -c -DUSE_TCL_STUBS -DTCL_NO_DEPRECATED -g -O2 -W
>> -Wall -pedantic
>> -I/Library/Frameworks/Mono.framework/Versions/2.2/include
>> -DHAVE_CONFIG_H -I.. -I.  -I"/usr/include" -fno-common registry.c -o
>> registry.o
>> In file included from ../cregistry/registry.h:35,
>>                 from registry.c:39:
>> How can I identify the problematic port in order to uninstall it?   Thanks!
> It is not a port. It is a standalone installation of Mono, installed by a means other than MacPorts.

Ok, so how can I remove it?  And why is MacPorts picking up on it?
Something in my PATH that I need to remove?



Obligatory current favourite quotes:

"We are all atheists about most of the gods that societies have ever
believed in. Some of us just go one god further."
--Richard Dawkins

"Religion is regarded by the common people as true, by the wise as
false, and by the rulers as useful".
 -- Seneca
"I have more confidence in the methods of science, based on the amazing
record of science and its ability over the centuries to answer
unanswerable questions, than I do in the methods of faith (what are they?)."
 -- David J. Gross "Physics Nobel Laureate"

"Atheism is a religion to the same extent that not collecting stamps is a
 -- seen on

More information about the macports-users mailing list