Older Port (ghostscript)

Ryan Schmidt ryandesign at macports.org
Mon Sep 19 11:05:12 PDT 2011

On Sep 19, 2011, at 10:27, Chencho Pc-cito wrote:

> I change macports.conf user to sbellver and do it ass root.

Please do not set the macports user to your user.

Probably the macports user (and all other users besides you) do not have permission to access items in your home directory -- and this is as it should be.

> Now works for a while, but finally have same error.
> :info:build ./obj/../soobj/echogs -e .dev -w- -l-dev2 -b -s -l-include -l./obj/../soobj/page -l-obj ./obj/../soobj/pksm ./obj/../soobj/gdevpbm.o ./obj/../soobj/gdevppla.o ./obj/../soobj/gdevmpla.o
> :info:build ./obj/../soobj/echogs -e .dev -w- -l-dev2 -b -s -l-include -l./obj/../soobj/page -l-obj ./obj/../soobj/pksmraw ./obj/../soobj/gdevpbm.o ./obj/../soobj/gdevppla.o ./obj/../soobj/gdevmpla.o
> :info:build ./obj/../soobj/echogs -e .dev -w- -l-dev2 -b -s -l-include -l./obj/../soobj/page -l-obj ./obj/../soobj/plan9bm ./obj/../soobj/gdevpbm.o ./obj/../soobj/gdevppla.o ./obj/../soobj/gdevmpla.o
> :info:build make[1]: *** No rule to make target `src/png.c', needed by `obj/../soobj/png.o'.  Stop.

That's not even remotely the same error.

I'm not particularly excited though about helping overcome errors with old ports, which have already been fixed by updating the ports to the latest versions. Why can't you use ghostscript 9?

More information about the macports-users mailing list