sshfs and Fuse4x

Puneet Kishor punk.kish at
Tue Sep 20 07:27:32 PDT 2011

On Sep 20, 2011, at 9:10 AM, Ryan Schmidt wrote:

> On Sep 19, 2011, at 23:11, Mr. Puneet Kishor wrote:
>> So, I first installed Macfuse (on Lion) and then sshfs and sshfs-gui from Macports. Quickly realized that Macfuse is hopelessly outdated. Following the suggestion at [], I uninstalled Macfuse and sshfs. Then I installed Fuse4X (latest version) and sshfs again. However, when I try to mount a remote server, I still get the following message
>> $sshfs Remote:/path/to/remote/home Remote -oauto_cache,reconnect,volname=Remote,defer_permissions
>> the MacFUSE file system is not available (-1)
>> the MacFUSE file system is not available (1)
>> Suggestions?
>> For now, I have installed at /usr/local/bin a version of sshfs I got from Fuse4x web site, and it is working fine, but I wouldn't mind going back to the MacPorts version in case that one is more reliably upgraded. In any case, would like to solve the above mystery.
> We don't support users installing software in /usr/local while using MacPorts; it can interfere with MacPorts software. Please remove or rename /usr/local, clean the affected ports, and try again.

Perhaps my sequence of actions wasn't clear. Here is what I did --

1. installed MacFuse by downloading it, double clicking, installing
2. installed MacPorts sshfs and sshfs-gui using `sudo port install <portname>`
3. $`sshfs` failed to work. Console showed that MacFuse failed to load because of wrong architecture
4. Saw ticket #30639
5. uninstalled MacFuse
6. uninstalled sshfs and sshfs using `sudo port uninstall <portname>`
7. installed Fuse4x by downloading it, double clicking, installing
8. reinstalled MacPorts sshfs

still got the above message

Looked in /System/Library/FileSystems and found fuse4x stuff in it... good.
Looked in /Library/FileSystems, made sure there was nothing related to MacFuse in it... good.

repeated #6-8 above. Still got the above message.

9. installed sshfs from Fuse4x web site. That got installed in /usr/local/bin. Everything works now.

More information about the macports-users mailing list