Mountain Lion/Xcode/Macports upgrade failure

Jeremy Huddleston Sequoia jeremyhu at
Tue Aug 7 12:02:33 PDT 2012

On Aug 7, 2012, at 11:55, Jason <macports at> wrote:

> All,
> Yes, I know this is a FAQ.  I've read them, I've tried them.  No luck.
> I have a MBP that was running Lion, Xcode, and up-to-date macports.  I
> then made the mistake of upgrading to Mountain Lion.  My openvpn still
> worked, but gkrellm/X11 would exit with error code 1.  So, thinking
> gentoo-like, I'll do 'port upgrade outdated'.

You need to follow the upgrade procedure (uninstall and re-build all ports).

> I'll be honest, I don't remember what the error was, I do know the good
> idea of the moment was to install the latest Xcode.  This went fine.
> Then I got the 'unable to find make' problem.  A bunch of sites advised
> going into Xcode -> Preferences -> Downloads and pulling in Command Line
> Utils.  But it wouldn't show for me.  I've rebooted, reinstalled,
> xcode-switch'd, to no avail.

Do you have a (free) ADC account?  You need to sign in with it to see the download, or you can just get it directly from instead of launching the XCode GUI.


More information about the macports-users mailing list