Ulrich Wienands wienands at
Sat Feb 4 18:53:59 PST 2012

I would like to install wxWidgets and wxpython and start python gui programming.

So I install python27... ok
I try py27-wxpython: no go; it claims wxWidgets cannot install on ppc:
------ Error msg I get:
 sudo port install py27-wxpython
Warning: port definitions are more than two weeks old, consider using selfupdate
--->  Computing dependencies for py27-wxpython
Error: Cannot install py27-wxpython for the arch(s) 'i386' because
Error: its dependency wxWidgets does not build for the required
arch(s) by default
Error: and does not have a universal variant.
Error: Unable to execute port: architecture mismatch
To report a bug, see <>
------- End error msg.

So I poke around in the list of ports and come across
wxWidgets-python, which in fact says in the port file that it is mean
for py**-wxpython.

Installing that... works fine (I use the Carbon variant since I run on
Tiger/PPC). I now have python27 installed as well as wxWidgets-python.

However, py27-wxpython still won't install. I try port -f to see if I
could force the issue, but no. Same error as above. (Note that the
error msg. is slightly confusing, but it does try to build for ppc but
can't get wxWidgets). It is true that wxWidgets' portfile seems to
require i386 so I am out of luck there; but why is wxWidgets-python
not enough??

Thanks for any insight. Again, this OS X 10.4.11 on PPC.


More information about the macports-users mailing list