Help with Lion's symbolic links

Brandon Allbery allbery.b at
Mon Feb 6 21:12:25 PST 2012

On Tue, Feb 7, 2012 at 00:03, Justin C. Walker <justin at> wrote:

> On Feb 6, 2012, at 18:40 , M A wrote:
> > I apologize for raising an issue that is not specific to macports, but
> > Google hasn't provided me an answer. In any case, after upgrading my
> > system to Lion I find that I can no longer save to symbolic links to a
> > directory in standard Mac GUI applications.
> Just tried this with 10.7.1 on my laptop.  I created a directory in /tmp;
> sym-linked it to another in /tmp; created a file in TextEdit; and then
> saved it to the sym-linked directory w/o a problem.

For what it's worth, I've seen it in 10.7.2 but not 10.7.1 (it broke a file
symlink I'd been using, in fact).  I haven't tried it on the just-released
10.7.3 yet.  Symlinks (both file and directory) are not selectable in Cocoa
file selection dialogs.  In 10.7.0 and 10.7.1 I could navigate to a
directory symlink, but the application would present the target path
instead of the symlink path as the current folder on the next use (this
also happened in Snow Leopard).

brandon s allbery                                      allbery.b at
wandering unix systems administrator (available)     (412) 475-9364 vm/sms
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list