Error on "sudo port -v upgrade outdated"

Kok-Yong Tan ktan at
Mon Jul 9 06:48:26 PDT 2012

On 7/9/12 09:27, Kok-Yong Tan wrote:
> On 7/9/12 09:22, Chris Jones wrote:
>> Hi,
>>> So noted. I haven't done anything yet. However, it seems apparent that
>>> I've got to change *SOMETHING* to get MacPorts to compile...
>> Jeremy beat me to it ! AFAIK, MacPorts should already be using gcc 
>> 4.2 with your combination of Xcode and OSX. I don't know why its 
>> using gcc 4.0
>>  - Does it do this for all ports, or just the one that fails ?
>>  - Have you altered your macports.conf file at all ?
>> cheers Chris
> Nah, I don't fiddle with the macports.conf file.  I just issue 
> commands on the MacPorts level (i.e., "sudo port -v ...") and refrain 
> from touching any config files.  I have tried upgrading individual 
> ports--hoping that a "sudo port -v upgrade outdated" will take care of 
> all of them (including recursive upgrades) for me.

Oops.  That should be "I have *NOT* tried upgrading individual 
ports--hoping that..."

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 6240 bytes
Desc: S/MIME Cryptographic Signature
URL: <>

More information about the macports-users mailing list