git bash_completion does not work - solved (?)

Barrie Stott zen146410 at
Sat Jul 21 03:51:17 PDT 2012

On 21 Jul 2012, at 11:07, Ryan Schmidt wrote:

> On Jul 21, 2012, at 04:53, Barrie Stott wrote:
>> On 20 Jul 2012, at 16:08, Clemens Lang wrote:
>>> On Fri, Jul 20, 2012 at 09:56:24AM -0500, Ryan Schmidt wrote:
>>>> I am still not sure what to change or how to verify it was successful.
>>>> In Lion's, I have opened Preferences -> Settings ->
>>>> Shell, checked the "Run command" box, and filled in
>>>> "/opt/local/bin/bash -l". The "Run inside shell" checkbox is not
>>>> checked. The bash port is installed. If I open a new terminal window
>>>> and type "echo $SHELL" it still prints "/bin/bash". Is that a correct
>>>> way to verify that these steps were not successful? What else should I
>>>> be doing?
>>> Try echo $BASH_VERSION. It should print something along the line of
>>> 4.2.something. If it doesn't you're not using MacPorts bash.
>> I upgraded my system this morning and I now have:
>> bash @4.2.29_0+universal (active)
>> bash-completion @2.0_1 (active)
>> I ran the following:
>> gbs:~ $ echo $BASH_VERSION
>> 3.2.48(1)-release
>> gbs:~ $ /bin/bash --version
>> GNU bash, version 3.2.48(1)-release (x86_64-apple-darwin10.0)
>> gbs:~ $ which bash
>> /opt/local/bin/bash
>> gbs:~ $ bash --version
>> GNU bash, version 4.2.29(2)-release (i386-apple-darwin10.8.0)
>> The results disagree with what Clemens said. 
> But have you actually followed the instructions from earlier in this thread about how to change your shell from /bin/bash to /opt/local/bin/bash? You need to do that first.

I have now edited /etc/shells with MacVim to add /opt/local/bin/bash as the first in the list. I then ran 'chsh -s /opt/local/bin/bash'. I had already done what you suggested in Terminal's Preferences -> Settings -> Shell. I removed all terminals, opened a new one and typed 'echo $BASH_VERSION'. The result was the same as before: 3.2.48(1)-release. What have I missed?


More information about the macports-users mailing list