Ruby 1.9

Jasper Frumau jasperfrumau at
Sat Jun 9 18:31:23 PDT 2012

On Fri, Jun 8, 2012 at 11:08 PM, Jeremy Lavergne <jeremy at
> wrote:

> >   rb-rubygems @1.3.7_0+ruby (active)
> So your gems are ruby are presumably 1.8.7 and your binary is ruby 1.9.3.

Yes , I uninstalled rubygems and added rb-rubygems + ruby19

jaspersmbp:wpscan jasper$ sudo port install rb-rubygems +ruby19
--->  Fetching archive for libffi
--->  Attempting to fetch
libffi-3.0.11_0+universal.darwin_11.i386-x86_64.tbz2 from
--->  Fetching distfiles for libffi
--->  Attempting to fetch libffi-3.0.11.tar.gz from
--->  Verifying checksum(s) for libffi
-------------------- cut  ----------------------------
--->  Fetching distfiles for rb-rubygems
--->  Verifying checksum(s) for rb-rubygems
--->  Extracting rb-rubygems
--->  Applying patches to rb-rubygems
--->  Configuring rb-rubygems
--->  Building rb-rubygems
--->  Staging rb-rubygems into destroot
--->  Installing rb-rubygems @1.3.7_0+ruby19
--->  Activating rb-rubygems @1.3.7_0+ruby19
--->  Cleaning rb-rubygems
--->  Updating database of binaries: 100.0%
--->  Scanning binaries for linking errors: 100.0%
--->  Found 717 broken file(s), matching files to ports
--->  Found 110 broken port(s), determining rebuild order
--->  Rebuilding in order
     glib2 @2.32.3 +universal

Then I found out I all of the sudden had many broken ports and glib2 failed
to build. Deactivated libelf and upgraded outdated. Will have to see if I
can rid of libelf. It is a pain every upgrade I do. But it depends on four
ports that depend on several others. Seems to be rather complicated..

jaspersmbp:wpscan jasper$ port echo depends:libelf
jaspersmbp:wpscan jasper$ port echo depends:bug-buddy

Then building Kerberos I had another conflict:

--->  Computing dependencies for kerberos5
Error: Unable to exec port: Can't install kerberos5 because conflicting
ports are installed: e2fsprogs
To report a bug, follow the instructions in the guide:

I deactivated e2fsprogs and continued

In the meanwhile I tested wpscan with newly added alias and newly built
rb-gems and got another error:

ruby wpscan.rb
dlopen(/opt/local/lib/ruby/gems/1.8/gems/ffi-1.0.11/lib/ffi_c.bundle, 9):
Library not loaded: /opt/local/lib/libffi.5.dylib
  Referenced from:
  Reason: image not found -

so I installed that one again as well as typhoeus. Still no joy:

jaspersmbp:wpscan jasper$ sudo uninstall typhoeus
Preparing Uninstall...
^Cjaspersmbp:wpscan jasper$ sudo gem uninstall typhoeus
Successfully uninstalled typhoeus-0.4.2
jaspersmbp:wpscan jasper$ sudo gem install typhoeus
Successfully installed typhoeus-0.4.2
1 gem installed
Installing ri documentation for typhoeus-0.4.2...
Installing RDoc documentation for typhoeus-0.4.2...
jaspersmbp:wpscan jasper$ ruby wpscan.rb
[ERROR] cannot load such file -- typhoeus
[TIP] Try to run 'gem install typhoeus' or 'gem install --user-install
typhoeus'. If you still get an error, Please see README file or

When I installed typhoeus in a different way I found out Gem is still using
Ruby 1.8:

jaspersmbp:wpscan jasper$ sudo gem install --user-install typhoeus
warning: Insecure world writable dir /usr/local in PATH, mode 040777
WARNING:  You don't have /Users/jasper/.gem/ruby/1.8/bin in your PATH,
      gem executables will not run.
Successfully installed typhoeus-0.4.2
1 gem installed
Installing ri documentation for typhoeus-0.4.2...
Installing RDoc documentation for typhoeus-0.4.2...

I  don't get it..

$ port variants rb-rubygems
> rb-rubygems has the variants:
> [+]ruby: add Ruby 1.8.7 support
>     * conflicts with ruby186 ruby19
>   ruby186: add Ruby 1.8.6 support
>     * conflicts with ruby ruby19
>   ruby19: add Ruby 1.9 support
>     * conflicts with ruby ruby186
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list