git-core stalling during build

Lee Bast x-lists at
Tue Apr 23 17:37:20 PDT 2013

Doh, I've resolved this, thank you for your suggestions.
	Turned out to be an embarrassingly simple issue though I'm sorry to say. I was doing some other work in a root shell, and while I typically sudo install I also hadn't really thought about it one way or the other either until now, since every other time it hasn't mattered whether I used sudo port install or issued port install from root. Since 1.8.2 under 10.8 though it appears that git-core does not like that, at least on my system. Interestingly under 10.7 on a different system git-core installs just fine under the root shell. Out of curiosity I also tried installing mplayer2 as a stress test since it has a significant number of dependencies, and it also worked without issue.
	All of that is academic though. I don't know why git-core alone amongst everything else would stall in a root shell but using sudo is of course decent practice in general anyway. I feel very dumb for not trying across multiple users on the same system first rather then trying other shells and other systems first.

Thanks again very much for the help.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 4112 bytes
Desc: not available
URL: <>

More information about the macports-users mailing list