Problem with gcc4.7 and call_once

Brian D. McGrew brian at
Fri Aug 9 08:21:42 PDT 2013

Appreciate the help!

In the meantime, I'Ll keep my original /opt/local tarred up and saved and
use my hand cranked gcc, as it seems to work just fine.  It's just an
out-of-tree build as you said.


On 8/9/13 8:17 AM, "Jeremy Huddleston Sequoia" <jeremyhu at>

>On Aug 9, 2013, at 6:27, Brian D. McGrew <brian at> wrote:
>> Well I could be going in the wrong direction, I'm not the foremost
>> on ports yet, but what I do know is this:
>> If I port edit gcc48 and add --enable-libstdcxx-threads and then port
>> install -s gcc48, when I run gcc -v I do see the option that I just
>> No question, the option IS there.  But the test program still doesn't
>Yes, I would expect there to be no change in behavior since
>--enable-libstdcxx-threads is on by default (thus your adding it has no
>effect other than to show it in 'gcc -v'
>> If I rebuild gcc-4.8.1 from source by hand using the same configuration
>> options from gcc-mp -v and add --enable-libstdcxx-threads at
>> time and do a make install over top of the existing gcc-mp, everything
>> works fine.  
>> Now I'm really confused.
>Yes, something is different between your out-of-tree-build and your
>in-tree build.  I'll try to repro your working case and then bisect the
>It would be great if someone without GPL3phobia could look at this.  It's
>probably rather simple to triage with source access, but at least having
>a working and broken build configurations from the same sources will let
>me bisect the build configurations.

More information about the macports-users mailing list