Problem with gcc4.7 and call_once

Jeremy Huddleston Sequoia jeremyhu at
Fri Aug 9 09:02:54 PDT 2013

On Aug 9, 2013, at 8:23, Brian D. McGrew <brian at> wrote:

> One more questionŠ  you know a lot more about port than I so I have a no
> reason to doubt when you say it's on by default.  But in the port
> installed versions when I do a gcc-mp -v, I do not see
> --enable-libstdcxx-threads in the configured line.  When I do the same on
> my hand cranked version, I do see the option on the configured line.

Yes.  gcc -v just reports back the configure options passed in.  Ones that are on by default are not printed unless you actually specified them.


> -b
> On 8/9/13 8:17 AM, "Jeremy Huddleston Sequoia" <jeremyhu at>
> wrote:
>> On Aug 9, 2013, at 6:27, Brian D. McGrew <brian at> wrote:
>>> Well I could be going in the wrong direction, I'm not the foremost
>>> expert
>>> on ports yet, but what I do know is this:
>>> If I port edit gcc48 and add --enable-libstdcxx-threads and then port
>>> install -s gcc48, when I run gcc -v I do see the option that I just
>>> added.
>>> No question, the option IS there.  But the test program still doesn't
>>> run.
>> Yes, I would expect there to be no change in behavior since
>> --enable-libstdcxx-threads is on by default (thus your adding it has no
>> effect other than to show it in 'gcc -v'
>>> If I rebuild gcc-4.8.1 from source by hand using the same configuration
>>> options from gcc-mp -v and add --enable-libstdcxx-threads at
>>> configuration
>>> time and do a make install over top of the existing gcc-mp, everything
>>> works fine.  
>>> Now I'm really confused.
>> Yes, something is different between your out-of-tree-build and your
>> in-tree build.  I'll try to repro your working case and then bisect the
>> two.
>> It would be great if someone without GPL3phobia could look at this.  It's
>> probably rather simple to triage with source access, but at least having
>> a working and broken build configurations from the same sources will let
>> me bisect the build configurations.
>> Thanks,
>> Jeremy

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 4145 bytes
Desc: not available
URL: <>

More information about the macports-users mailing list