webkit-gtk requires libc++ -- MacOS 10.9 or XCode 5?

Ryan Schmidt ryandesign at macports.org
Sat Dec 7 09:13:26 PST 2013

On Dec 7, 2013, at 09:31, Richard Cobbe wrote:

> MacPorts 2.2.1, MacOS 10.8.5, XCode 4.6.3.
> I tried to do a "port selfupdate; port upgrade outdated" this morning, and
> it failed when attempting to install webkit-gtk:
>    Error: webkit-gtk is not supported for this installation of MacPorts.
>    It requires libc++ be selected as your C++ runtime.  Please use
>    webkit-gtk-2.0 instead
> I'm only using webkit-gtk as a dependency for gnucash, which doesn't appear
> to like webkit-gtk-2.0.  Based on <http://trac.macports.org/ticket/41560>,
> it looks like I'm out of luck on this package until I upgrade to Mavericks.
> Is that correct?  (I'm finding the comments on that bug to be a little hard
> to interpret.)  Or is it an XCode 4 vs. XCode 5 issue?

You’re fine on Mountain Lion, Lion, or even Snow Leopard: just deactivate webkit-gtk and install webkit-gtk-2.0 in its place:

sudo port -f deactivate webkit-gtk
sudo port install webkit-gtk-2.0

Then you can upgrade the rest of your outdated ports. gnucash should have no problem automatically using webkit-gtk-2.0 instead of webkit-gtk once you do that.

I’ll try to automate this soon so that this manual intervention isn’t needed anymore, but for now it is.

More information about the macports-users mailing list