webkit-gtk requires libc++ -- MacOS 10.9 or XCode 5?

Richard Cobbe cobbe at ccs.neu.edu
Sun Dec 8 13:23:08 PST 2013

On Sat, Dec 07, 2013 at 11:13:26AM -0600, Ryan Schmidt wrote:
> On Dec 7, 2013, at 09:31, Richard Cobbe wrote:
> > MacPorts 2.2.1, MacOS 10.8.5, XCode 4.6.3.
> >
> > I tried to do a "port selfupdate; port upgrade outdated" this morning, and
> > it failed when attempting to install webkit-gtk:
> >
> >    Error: webkit-gtk is not supported for this installation of MacPorts.
> >    It requires libc++ be selected as your C++ runtime.  Please use
> >    webkit-gtk-2.0 instead


> You’re fine on Mountain Lion, Lion, or even Snow Leopard: just deactivate
> webkit-gtk and install webkit-gtk-2.0 in its place:
> sudo port -f deactivate webkit-gtk
> sudo port install webkit-gtk-2.0
> Then you can upgrade the rest of your outdated ports. gnucash should have
> no problem automatically using webkit-gtk-2.0 instead of webkit-gtk once
> you do that.
> I’ll try to automate this soon so that this manual intervention isn’t
> needed anymore, but for now it is.

Ah, thanks!  That works.  I did try something similar before posting the
original message, but it didn't work.  I think the key difference is that,
after uninstalling webkit-gtk and all of its dependents, I went straight to
attempting to reinstall gnucash, without installing webkit-gtk-2.0 first.

Once I did that, everything is fine.



More information about the macports-users mailing list