gcc48/gcc49: isalnum/isgraph: Undefined symbols for architecture x86_64

Brian D. McGrew brian at visionpro.com
Wed Nov 6 13:27:50 PST 2013

Hello all,

I’m getting an undefined symbol for isalnum and isgraph using g++-mp-4.8.

I found this article here: http://stackoverflow.com/questions/19649421/something-odd-happened-to-c-11-in-mavericks which mentions the issue in Mavericks and the Xcode command line tools.  However, I’m using MP and the g++ from mp when trying to build.  And yes, I rebuilt ports, from scratch, when I upgraded (clean install) to Mavericks.

It could just be me missing something, but I’ve tried everything I can think of and every combination of google searches to figure this one out.  The code is very simple (I think).  Oh, and yes, I did a +universal when I installed gcc49 and gcc48.  And if it matters, I installed gcc49 (with libgcc) before gcc48.  When I tried gcc48 then gcc49 I got an error about libgcc, but doing it the other way works.

What am I missing???



#include <ctype.h>

typedef char Boolean

static inline int
teststring(char p, Boolean alnum)
    if (alnum)
        return isalnum(p);

    return isgraph(p);

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.macosforge.org/pipermail/macports-users/attachments/20131106/07787454/attachment.html>

More information about the macports-users mailing list