xulrunner +universal variant

sarvi sarvi at yahoo.com
Tue Oct 15 17:09:22 PDT 2013

Just to be sure I cleanedup and uninstalled the macport and reinstalled
macport from scratch
and then tried installing xulrunner as follows

localhost:build sarvi$ sudo port variant xulrunner
xulrunner has the variants:
   debug: build with debugging symbols
   gnome: use gnome libraries where appropriate
   internal_dependencies: Use internal versions of nspr and nss

since nss was causing the install to fail with +universal as well as
-universal I tried the following
to skip nss. the above seems to indicate nss will not be an external

sudo port -d install xulrunner +internal_dependencies

This ended with the following error
checking for platform specific tests to compile... Mac OS X
checking for a2x... :
checking for asciidoc... :
configure: WARNING: Could not find a2x.
configure: WARNING: Could not find asciidoc.
./configure: line 16433: PKG_PROG_PKG_CONFIG: command not found
./configure: line 16440: syntax error near unexpected token `FLAC,'
./configure: line 16440: `		PKG_CHECK_MODULES(FLAC, flac >= 1.2.1,
ac_cv_flac=yes, ac_cv_flac=no)'
Command failed:  cd
&& ./configure --prefix=/opt/local --disable-dependency-tracking 
Exit code: 2
Error: Failed to configure audiofile, consult
Error: org.macports.configure for port audiofile returned: configure
failure: command execution failed
DEBUG: Error code: NONE
DEBUG: Backtrace: configure failure: command execution failed
    while executing
"$procedure $targetname"
Warning: targets not executed for audiofile: org.macports.activate
org.macports.configure org.macports.build org.macports.destroot
Error: Failed to install audiofile
DEBUG: could not read "/opt/local/share/man/man1/glibtoolize.1.gz": no such
file or directory
    while executing
"::file type $file"
Please see the log file for port audiofile for details:

Error: The following dependencies were not installed: esound audiofile
findutils gconf dbus-glib dbus pkgconfig glib2 libffi xz zlib gtk-doc
docbook-xml docbook-xml-4.1.2 docbook-xml-4.2 xmlcatmgr docbook-xml-4.3
docbook-xml-4.4 docbook-xml-4.5 docbook-xml-5.0 docbook-xsl gnome-doc-utils
iso-codes libxslt libxml2 py27-libxml2 python27 bzip2 db46 db_select libedit
openssl python_select sqlite3 rarian gobject-introspection cairo fontconfig
freetype libpng libpixman xorg-libXext xorg-libX11 xorg-bigreqsproto
xorg-inputproto xorg-kbproto xorg-libXau xorg-xproto xorg-libXdmcp
xorg-libxcb xorg-libpthread-stubs xorg-xcb-proto xorg-util-macros
xorg-xcmiscproto xorg-xextproto xorg-xf86bigfontproto xorg-xtrans
xorg-xcb-util xrender xorg-renderproto gtk2 atk gdk-pixbuf2 jasper jpeg tiff
hicolor-icon-theme pango Xft2 harfbuzz graphite2 shared-mime-info intltool
p5.12-getopt-long p5.12-pathtools p5.12-scalar-list-utils p5.12-xml-parser
xorg-libXcomposite xorg-compositeproto xorg-libXfixes xorg-fixesproto
xorg-libXcursor xorg-libXdamage xorg-damageproto xorg-libXi xorg-libXinerama
xorg-xineramaproto xorg-libXrandr xorg-randrproto orbit2 libidl policykit
heimdal lcms libcanberra gstreamer1 bison flex gzip texinfo gtk3 at-spi2-atk
at-spi2-core xorg-libXevie xorg-evieproto xorg-libXtst xorg-recordproto
xorg-libice xorg-libsm dbus-python27 py27-gobject libvorbis libogg
To report a bug, follow the instructions in the guide:
Error: Processing of port xulrunner failed

View this message in context: http://mac-os-forge.2317878.n4.nabble.com/xulrunner-universal-variant-tp231569p231581.html
Sent from the MacPorts - Users mailing list archive at Nabble.com.

More information about the macports-users mailing list